summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.39.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-input-wacom/xf86-input-wacom-0.39.0.ebuild')
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.39.0.ebuild26
1 files changed, 15 insertions, 11 deletions
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.39.0.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.39.0.ebuild
index 6810d3ce8285..ee39fbabc711 100644
--- a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.39.0.ebuild
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.39.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -26,16 +26,6 @@ RDEPEND="dev-libs/libwacom
DEPEND="${RDEPEND}
x11-base/xorg-proto"
-pkg_setup() {
- linux-info_pkg_setup
-
- XORG_CONFIGURE_OPTIONS=(
- --with-systemd-unit-dir="$(systemd_get_systemunitdir)"
- --with-udev-rules-dir="$(get_udevdir)/rules.d"
- $(use_enable debug)
- )
-}
-
pkg_pretend() {
linux-info_pkg_setup
@@ -65,3 +55,17 @@ pkg_pretend() {
fi
fi
}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ xorg-3_pkg_setup
+}
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ --with-systemd-unit-dir="$(systemd_get_systemunitdir)"
+ --with-udev-rules-dir="$(get_udevdir)/rules.d"
+ $(use_enable debug)
+ )
+ xorg-3_src_configure
+}