summaryrefslogtreecommitdiff
path: root/x11-drivers/nvidia-drivers/nvidia-drivers-535.54.03.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/nvidia-drivers/nvidia-drivers-535.54.03.ebuild')
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-535.54.03.ebuild68
1 files changed, 3 insertions, 65 deletions
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-535.54.03.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-535.54.03.ebuild
index 1e24166af1ae..66b37eefdede 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-535.54.03.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-535.54.03.ebuild
@@ -119,69 +119,6 @@ pkg_setup() {
selection of another option that requires it such as CONFIG_KVM."
linux-mod-r1_pkg_setup
-
- # do some extra checks manually as it gets messy to handle builtin-only
- # and some other conditional checks through CONFIG_CHECK
- # TODO?: maybe move other custom checks here for uniformity
- local warn=()
-
- if linux_chkconfig_builtin DRM_NOUVEAU; then
- # suggest =m given keeps KMS_HELPER enabled and can serve as fallback
- warn+=(
- " CONFIG_DRM_NOUVEAU: is builtin (=y), and will prevent loading NVIDIA"
- " modules (can be safely kept as a module (=m) instead)."
- )
- fi
-
- if linux_chkconfig_builtin DRM_SIMPLEDRM; then
- # wrt prebuilts, Fedora is pushing =y and gentoo-kernel-bin uses its
- # configs (bug #840439), but without Fedora's kernel patch to
- # workaround this issue (which is unlikely to work for us anyway)
- # https://github.com/NVIDIA/open-gpu-kernel-modules/issues/228
- warn+=(
- " CONFIG_DRM_SIMPLEDRM: is builtin (=y), and may conflict with NVIDIA"
- " (i.e. blanks when X/wayland starts, and tty loses display)."
- " For prebuilt kernels, unfortunately no known good workarounds."
- )
- fi
-
- if ! linux_chkconfig_present FB_EFI &&
- ! linux_chkconfig_present FB_SIMPLE &&
- ! linux_chkconfig_present FB_VESA
- then
- # nvidia-drivers does not handle the tty (beside mode restoration) but,
- # given few options are viable, try to warn if all missing
- warn+=(
- " CONFIG_FB_(EFI|SIMPLE|VESA): none set, but note at least one is normally"
- " needed to get a display for the tty console. In most cases, it is"
- " recommended to enable FB_EFI=y and disable FB_SIMPLE (can be quirky)."
- " Non-EFI systems are likely to want FB_VESA=y. Users with multiple GPUs"
- " or not using the tty may be able to safely ignore this warning."
- )
- fi
-
- if kernel_is -ge 5 18 13; then
- if linux_chkconfig_present FB_SIMPLE; then
- warn+=(
- " CONFIG_FB_SIMPLE: is set, recommended to disable and switch to FB_EFI or"
- " FB_VESA as it currently may be broken with >=kernel-5.18.13 + NVIDIA:"
- " https://github.com/NVIDIA/open-gpu-kernel-modules/issues/341"
- " (feel free to ignore this if it works for you)"
- )
- fi
-
- if linux_chkconfig_present SYSFB_SIMPLEFB &&
- { linux_chkconfig_present FB_EFI || linux_chkconfig_present FB_VESA; }
- then
- warn+=(
- " CONFIG_SYSFB_SIMPLEFB: is set, this may prevent FB_EFI or FB_VESA"
- " from providing a working tty console display (ignore if unused)."
- )
- fi
- fi
-
- (( ${#warn[@]} )) &&
- ewarn "Detected potential configuration issues with used kernel:${warn[*]/#/$'\n'}"
}
src_prepare() {
@@ -356,8 +293,9 @@ $(use amd64 && usev !abi_x86_32 "
Note that without USE=abi_x86_32 on ${PN}, 32bit applications
(typically using wine / steam) will not be able to use GPU acceleration.")
-For general information on using ${PN}, please see:
-https://wiki.gentoo.org/wiki/NVIDIA/nvidia-drivers"
+For additional information or for troubleshooting issues, please see
+https://wiki.gentoo.org/wiki/NVIDIA/nvidia-drivers and NVIDIA's own
+documentation that is installed alongside this README."
readme.gentoo_create_doc
if use modules; then