summaryrefslogtreecommitdiff
path: root/x11-base/xorg-proto
diff options
context:
space:
mode:
Diffstat (limited to 'x11-base/xorg-proto')
-rw-r--r--x11-base/xorg-proto/Manifest2
-rw-r--r--x11-base/xorg-proto/xorg-proto-2021.4.99.2.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/x11-base/xorg-proto/Manifest b/x11-base/xorg-proto/Manifest
index ddbd1ec98cf6..4a9e1a9bf35b 100644
--- a/x11-base/xorg-proto/Manifest
+++ b/x11-base/xorg-proto/Manifest
@@ -1,4 +1,6 @@
+DIST xorgproto-2021.4.99.2.tar.gz 1143087 BLAKE2B eabdbc903a058a9be919192ac71fc95cedc2ff58e131a0eae6454be1e03714fb592d020ce8d9a4915a620de2a4d1c7cf2c5939c53ba96199f2a2ea579c450606 SHA512 34c4cb2aa97568be5ac5480c86122e9733afab3d17d48d170636aa10b39a99d6d637864d872ab78040a468ee3896a1aa42f5124bc8a4901dbb4b543eada7a607
DIST xorgproto-2021.4.tar.gz 1141941 BLAKE2B 016a3c2f30ed064855de2a13d86a4b7bc9420ff10e8ac3ba97e08512fef6f0495a69dcaea7f12c7d8694a52284b500a38aee73de7bf2ff0a295715354d04eab0 SHA512 5f4c94d3ee20635f2358d7644be54d5e291bafba15a7713583acbb3564c2799da4ba33ffba625273fe015e4ab733cbaec146467804fd2174eb5fd1ff3bf21019
+EBUILD xorg-proto-2021.4.99.2.ebuild 1191 BLAKE2B 3b074d900922af4633893e60fb07cff71a8868ed33ca7a7ef4c5d3dcf16853006e9978e82c77aec781225940e864a6e44e3ee73209d244ee0d98a98aca48d14e SHA512 f454d47c50d1caf590ae528829031abf416283eb51415ac80a2c1d90154830b9c0fc0dbdaa8aba151fb357807867a4b404563c2a4031bc5f95c6b643b68eb758
EBUILD xorg-proto-2021.4.ebuild 1183 BLAKE2B a546eb4286819d9699dc04ca7f8e9f4114cfabcd8dc7e5d214278e1cb8ac71f4b1dda561c23f6114ab6afd78ac910029b36fd468746b098e4eec80c94e84f5c4 SHA512 ecbacd72b45f800b16c8e72a17dd60e868376fd9ba19368a99760ebbf0ebf104ffbde15affec7ed56a3d7012ca0ca725262c758a08ef70b2781d20a847fb2c9c
EBUILD xorg-proto-9999.ebuild 1191 BLAKE2B 3b074d900922af4633893e60fb07cff71a8868ed33ca7a7ef4c5d3dcf16853006e9978e82c77aec781225940e864a6e44e3ee73209d244ee0d98a98aca48d14e SHA512 f454d47c50d1caf590ae528829031abf416283eb51415ac80a2c1d90154830b9c0fc0dbdaa8aba151fb357807867a4b404563c2a4031bc5f95c6b643b68eb758
MISC metadata.xml 230 BLAKE2B 70bf59e64305ef14908197f2aa7ffbc1769ade265097da68e001245451658af5921760c91cb74aae717543ea0017e2471fd94bfc5c4c447d2d60e2c23aa3b007 SHA512 d7a2643abd1904cc5ff4d91cbb6f1baeb7f75fd1db542c5e14f19412f4f0bd4b903f8e703a7662ba7482c79dac5529057760b6427599d35e0842755fd946e057
diff --git a/x11-base/xorg-proto/xorg-proto-2021.4.99.2.ebuild b/x11-base/xorg-proto/xorg-proto-2021.4.99.2.ebuild
new file mode 100644
index 000000000000..3544d1e5d5eb
--- /dev/null
+++ b/x11-base/xorg-proto/xorg-proto-2021.4.99.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+MY_PN="${PN/xorg-/xorg}"
+MY_P="${MY_PN}-${PV}"
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/${MY_PN}.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson python-any-r1
+
+DESCRIPTION="X.Org combined protocol headers"
+HOMEPAGE="https://gitlab.freedesktop.org/xorg/proto/xorgproto"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+ SRC_URI="https://xorg.freedesktop.org/archive/individual/proto/${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ $(python_gen_any_dep '
+ dev-python/python-libevdev[${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND=""
+
+python_check_deps() {
+ has_version -b "dev-python/python-libevdev[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_install() {
+ meson_src_install
+
+ mv "${ED}"/usr/share/doc/{xorgproto,${P}} || die
+}