summaryrefslogtreecommitdiff
path: root/x11-apps/xrandr
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/xrandr')
-rw-r--r--x11-apps/xrandr/Manifest2
-rw-r--r--x11-apps/xrandr/xrandr-1.5.2.ebuild23
2 files changed, 25 insertions, 0 deletions
diff --git a/x11-apps/xrandr/Manifest b/x11-apps/xrandr/Manifest
index 6d0b55b29017..c11bc1cb0454 100644
--- a/x11-apps/xrandr/Manifest
+++ b/x11-apps/xrandr/Manifest
@@ -1,3 +1,5 @@
DIST xrandr-1.5.1.tar.xz 171200 BLAKE2B 69cc080da24b8d00fcf60e9fb2d4c03d7b80b46d18888fa726ad4ba5847fcfcea4abeefa298fb833febe0549aec0636ed9087c8ef065f5166df6bd7f270dac1a SHA512 3d0d37e974b9dffb996276ee7fd676327fd0956e5f5f572dd142a651a35d3cdfa2f6dd415cf27bf87f306981957aba4cc014c12baebefcabaa5d66b78a114922
+DIST xrandr-1.5.2.tar.xz 174012 BLAKE2B 7c4afea6b8bc4361bde2565e930db98abb925b51d717e23c3ec95853aacf58b465f8c858652b8eebd7b0fdb289b4da4ab9235e571f61c8f77e4818efcb12de07 SHA512 b536e8f1e04094894aa52ae496725c58691b043860b3327c41d737b07b642a939733321b62f698032b11ba857208a6177600a3ca3295ff1be6ade4341cdc2747
EBUILD xrandr-1.5.1.ebuild 539 BLAKE2B 5773bca54f849c30697d2ce4095b54ddbba938163888399107d1655453be463558b251c203628570848442f5beded1103f8481b0b9aa2b542d6a80a9a181b3b1 SHA512 2f4403ba2d7f44f7c1c638874d7d58945aab39b5010059710c4a2d5784cff52577341b7a90ff01869aca6ec96de3967b362573aa2485b9e3835e6ca37297784e
+EBUILD xrandr-1.5.2.ebuild 546 BLAKE2B 66800e7f8d453eb1da3b40524d80e58444860dadccd4abcd67a2e1f3b123f84224a4c6ee55e3a4c0234f1a23b99007c25740567d9f8869b17999dfc5fdf10e30 SHA512 9dc6f9e7e9385fe819f63a6b41c4ccdd393feebf40fbb678c6611e6dbbf9c005a4c7701436ea89da369790559f8390f2aefcad36e105496bf30ac8c8b451cfcd
MISC metadata.xml 337 BLAKE2B 3003fb3f334179c653f32ef2a864a609df08a585981e15adb49cb63209530479c22c0ed5c5e62e64d3647b25b57e28af7a41d948af012ed450ad1afd6be23374 SHA512 e51bf78854aaa4634a164f04408ccc202983e118f987cb90469feefefe51ee4671ba9b3a329b71ab6806022c0e6beb32ff27c7ee35682945a3bb8fd1a40636c2
diff --git a/x11-apps/xrandr/xrandr-1.5.2.ebuild b/x11-apps/xrandr/xrandr-1.5.2.ebuild
new file mode 100644
index 000000000000..6588b0e6070d
--- /dev/null
+++ b/x11-apps/xrandr/xrandr-1.5.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+XORG_TARBALL_SUFFIX="xz"
+
+inherit xorg-3
+
+DESCRIPTION="primitive command line interface to RandR extension"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=x11-libs/libXrandr-1.5
+ x11-libs/libXrender
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+src_install() {
+ xorg-3_src_install
+ rm -f "${ED}"/usr/bin/xkeystone || die
+}