summaryrefslogtreecommitdiff
path: root/x11-apps/xditview/xditview-1.0.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/xditview/xditview-1.0.7.ebuild')
-rw-r--r--x11-apps/xditview/xditview-1.0.7.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-apps/xditview/xditview-1.0.7.ebuild b/x11-apps/xditview/xditview-1.0.7.ebuild
new file mode 100644
index 000000000000..c19d912e4a70
--- /dev/null
+++ b/x11-apps/xditview/xditview-1.0.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="display ditroff output"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="xft"
+
+RDEPEND="
+ x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libX11
+ xft? (
+ x11-libs/libXft
+ x11-libs/libXrender
+ media-libs/fontconfig
+ )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_with xft)
+ )
+ xorg-3_src_configure
+}