summaryrefslogtreecommitdiff
path: root/www-servers
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/Manifest.gzbin4538 -> 4540 bytes
-rw-r--r--www-servers/lighttpd/Manifest2
-rw-r--r--www-servers/lighttpd/lighttpd-1.4.69.ebuild237
-rw-r--r--www-servers/puma/Manifest2
-rw-r--r--www-servers/puma/puma-6.1.0.ebuild59
5 files changed, 300 insertions, 0 deletions
diff --git a/www-servers/Manifest.gz b/www-servers/Manifest.gz
index 531be73a3a0c..38fbb08b3558 100644
--- a/www-servers/Manifest.gz
+++ b/www-servers/Manifest.gz
Binary files differ
diff --git a/www-servers/lighttpd/Manifest b/www-servers/lighttpd/Manifest
index efdcccf160af..c1ac5b35e6ef 100644
--- a/www-servers/lighttpd/Manifest
+++ b/www-servers/lighttpd/Manifest
@@ -10,6 +10,8 @@ AUX lighttpd.service 257 BLAKE2B 7e60ad2f87ece8547cd3e39fc2121ea4664d9015722469a
AUX lighttpd.tmpfiles.conf 41 BLAKE2B a159ae17094377d927bcf51078d40c322e5213d62064a271a7a0cf5b32423b349ac13d2ebc38a8de5c6478823ac022e46eef60a830e6ae9598e848b8c220bc2f SHA512 3fda360423a7a406a2981de647dac6b4419fe60c649bf3cc21fad566e8513293f6e81d4f5b777eaf06a056beedbf44360a39894ca3a2d05d3fc3a2d26c339efe
DIST lighttpd-1.4.67.tar.xz 1039872 BLAKE2B e8e32970fe8b6e36fbee0c5104c8f42f846531c75689ad8e561e8eef9e92c69989a094d18ad65e4c404ea69d67dd960c57ef91773f9b5599bfd6072e5d4588d9 SHA512 acfde71675d1c54b4e805998d1dabaa291437181bdbca0d6a3a069584c4576d7585d2401f57f8691f23aaf6283a95ac61156789a055a2a7236fd305c1f248627
DIST lighttpd-1.4.68.tar.xz 1030612 BLAKE2B 5682194a9e124598daf22bca56826535ac48f1c89087238f2a455cd4cb0f12287ce79ab5a7b6ca966003772335e6a14d484658300e401c098b4e87a7207198c4 SHA512 137cf62e3c7b07d1dc4af50318f1ec67bbf60058ad1a4fef0b1c94668916e23cfcdf85fe9cd728163e55c1b21f4831b9ab922fcf6b6ba8e2a03b2f73a9694189
+DIST lighttpd-1.4.69.tar.xz 1045516 BLAKE2B 4b9c15bd69db5afcf40c3df41831d2fcecbb4149a8cfef582e7dfe80328d515a1021baa32c17e0f89d81c9726dbbe8480d9d319684d38a11961b28d2d0224e9c SHA512 9d174c8e0a192b4eb8218a9f76b0bd42f90030228600bb7bbe35ebb9e7bbaea36ee2732535c5cc6dab171294817837bfa26074ff84a37832dd89f57488b4071f
EBUILD lighttpd-1.4.67.ebuild 6001 BLAKE2B 2716620d5461d8cd94e8970b15bf201180045755dfd5a9a34cf6f3c730eb11fa4f8f014a2d22a80b6ca308e4e4f2e0db54bf0c7434bda1f318baed9d97ff0270 SHA512 00ea9635270477fec723574927e26b3540e164fc6636505e7754789335c3289dbd56324a5e15bca025fed9fa9019d89e10e94a54e812037c84a9c017bbb0c168
EBUILD lighttpd-1.4.68.ebuild 6140 BLAKE2B 4f90dc1c11a8d30f66466664e614ea36b2c33b645d9dd92acbe0ddd87f04c1c78cc1d4d4198529788d120b3fd0ea184a14dc05cd6e3050d09abf703d588b85cf SHA512 53ca9af5eac99f6d40c397de922663a23328fb36baf61f230b11cf5ce130a394883832c5c6f58475bec9ab97de7834fd8af07683c3ac411133acefaf6e295073
+EBUILD lighttpd-1.4.69.ebuild 6076 BLAKE2B a7839c7b76ebf861d3c02202d1622ae790eb3242ce5cf01b57d0726c92b690c3fc2b55cc415ce51ce77186b72cb3318f887c889ff5271761d4338cd8c6bef4bb SHA512 ac7e2031314135e8b80f97aca63e8f5306d4cd666633f55ae1fa97c3a326edbc54de275cd0124d2acbdda598f6c79a759aa33b68660b1be81facf2792a21d523
MISC metadata.xml 1763 BLAKE2B 906a9cf10ee127ce19e5184188158a0a82f79fb33dea289a74fbe24465a119893cdda65223dbae31ced1692ab9837e0cf591495e859de63ebafb198f4acc2fcc SHA512 c71be3ada914e18f6303fef04edae206237a41aa0b2c82dbc7e05a6dbdfd57d26762cf27f156c52a0e054802f98f5a242fb1b28f53e699c8ec363a36f4099ca0
diff --git a/www-servers/lighttpd/lighttpd-1.4.69.ebuild b/www-servers/lighttpd/lighttpd-1.4.69.ebuild
new file mode 100644
index 000000000000..d8c68c6d4ed0
--- /dev/null
+++ b/www-servers/lighttpd/lighttpd-1.4.69.ebuild
@@ -0,0 +1,237 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} )
+
+inherit lua-single meson readme.gentoo-r1 systemd tmpfiles
+
+DESCRIPTION="Lightweight high-performance web server"
+HOMEPAGE="https://www.lighttpd.net https://github.com/lighttpd"
+SRC_URI="https://download.lighttpd.net/lighttpd/releases-$(ver_cut 1-2).x/${P}.tar.xz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+brotli dbi gnutls kerberos ldap +lua maxminddb mbedtls mmap mysql +nettle nss +pcre php postgres rrdtool sasl selinux ssl sqlite +system-xxhash test unwind webdav xattr +zlib zstd"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="
+ lua? ( ${LUA_REQUIRED_USE} )
+ mysql? ( dbi )
+ postgres? ( dbi )
+ sqlite? ( dbi )
+ webdav? ( sqlite )
+"
+
+COMMON_DEPEND="
+ acct-group/lighttpd
+ acct-user/lighttpd
+ virtual/libcrypt:=
+ brotli? ( app-arch/brotli:= )
+ dbi? (
+ dev-db/libdbi
+ mysql? ( dev-db/libdbi-drivers[mysql] )
+ postgres? ( dev-db/libdbi-drivers[postgres] )
+ sqlite? ( dev-db/libdbi-drivers[sqlite] )
+ )
+ gnutls? ( net-libs/gnutls )
+ kerberos? ( virtual/krb5 )
+ ldap? ( >=net-nds/openldap-2.1.26:= )
+ lua? ( ${LUA_DEPS} )
+ maxminddb? ( dev-libs/libmaxminddb )
+ mbedtls? ( net-libs/mbedtls )
+ nettle? ( dev-libs/nettle:= )
+ nss? ( dev-libs/nss )
+ pcre? ( dev-libs/libpcre2 )
+ php? ( dev-lang/php:*[cgi] )
+ rrdtool? ( net-analyzer/rrdtool )
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( >=dev-libs/openssl-0.9.7:= )
+ system-xxhash? ( dev-libs/xxhash )
+ unwind? ( sys-libs/libunwind:= )
+ webdav? (
+ dev-libs/libxml2
+ sys-fs/e2fsprogs
+ )
+ xattr? ( kernel_linux? ( sys-apps/attr ) )
+ zlib? ( >=sys-libs/zlib-1.1 )
+ zstd? ( app-arch/zstd:= )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ elibc_musl? ( sys-libs/queue-standalone )
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ selinux? ( sec-policy/selinux-apache )
+"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( virtual/perl-Test-Harness )
+"
+
+# update certain parts of lighttpd.conf based on conditionals
+update_config() {
+ local config="${ED}/etc/lighttpd/lighttpd.conf"
+
+ # Enable php/mod_fastcgi settings
+ if use php; then
+ sed -i -e 's|#.*\(include.*fastcgi.*$\)|\1|' ${config} || die
+ fi
+
+ # Automatically listen on IPv6 if built with USE=ipv6 (which we now always do)
+ # bug #234987
+ sed -i -e 's|# server.use-ipv6|server.use-ipv6|' ${config} || die
+}
+
+pkg_setup() {
+ if use lua; then
+ lua-single_pkg_setup
+ fi
+
+ if ! use pcre ; then
+ ewarn "It is highly recommended that you build ${PN}"
+ ewarn "with perl regular expressions support via USE=pcre."
+ ewarn "Otherwise you lose support for some core options such"
+ ewarn "as conditionals and modules such as mod_re{write,direct}."
+ fi
+
+ DOC_CONTENTS="IPv6 migration guide:\n
+ http://redmine.lighttpd.net/projects/lighttpd/wiki/IPv6-Config"
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dmoduledir="$(get_libdir)"/${PN}
+
+ $(meson_feature brotli with_brotli)
+
+ # TODO: revisit (was off in autotools ebuild)
+ -Dwith_bzip=disabled
+
+ $(meson_feature dbi with_dbi)
+
+ # Unpackaged in Gentoo
+ -Dwith_libdeflate=disabled
+ # Obsolete
+ -Dwith_fam=disabled
+
+ $(meson_use gnutls with_gnutls)
+ $(meson_feature kerberos with_krb5)
+ $(meson_feature ldap with_ldap)
+
+ # TODO: revisit (was off in autotools ebuild)
+ -Dwith_libev=disabled
+
+ $(meson_feature unwind with_libunwind)
+
+ $(meson_use lua with_lua)
+ -Dlua_version=${ELUA}
+
+ $(meson_feature maxminddb with_maxminddb)
+ $(meson_use mbedtls with_mbedtls)
+
+ # TODO: revisit (was off in autotools ebuild)
+ -Dwith_mysql=disabled
+
+ $(meson_use nettle with_nettle)
+ $(meson_use nss with_nss)
+
+ # Obsolete
+ -Dwith_pcre=disabled
+
+ $(meson_use pcre with_pcre2)
+
+ # TODO: revisit (was off in autotools ebuild)
+ -Dwith_pgsql=disabled
+
+ $(meson_feature sasl with_sasl)
+ $(meson_use ssl with_openssl)
+ $(meson_feature system-xxhash with_xxhash)
+ $(meson_feature webdav with_webdav_props)
+ $(meson_feature webdav with_webdav_locks)
+
+ # Unpackaged in Gentoo
+ -Dwith_wolfssl=false
+
+ $(meson_use xattr with_xattr)
+ $(meson_feature zlib with_zlib)
+ $(meson_feature zstd with_zstd)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # Init script stuff
+ newinitd "${FILESDIR}"/lighttpd.initd-r1 lighttpd
+ newconfd "${FILESDIR}"/lighttpd.confd lighttpd
+
+ # Configs
+ insinto /etc/lighttpd
+ newins "${FILESDIR}"/conf/lighttpd.conf-r1 lighttpd.conf
+ doins "${FILESDIR}"/conf/mime-types.conf
+ doins "${FILESDIR}"/conf/mod_cgi.conf
+ doins "${FILESDIR}"/conf/mod_fastcgi.conf
+
+ # Update lighttpd.conf directives based on conditionals
+ update_config
+
+ # Docs
+ dodoc AUTHORS README NEWS doc/scripts/*.sh
+ newdoc doc/config/lighttpd.conf lighttpd.conf.distrib
+ readme.gentoo_create_doc
+
+ docinto txt
+ dodoc doc/outdated/*.txt
+
+ doman doc/*.8
+
+ # Logrotate
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/lighttpd.logrotate-r1 lighttpd
+
+ keepdir /var/l{ib,og}/lighttpd /var/www/localhost/htdocs
+ fowners lighttpd:lighttpd /var/l{ib,og}/lighttpd
+ fperms 0750 /var/l{ib,og}/lighttpd
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfiles.conf ${PN}.conf
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+
+ readme.gentoo_print_elog
+
+ if [[ -f ${EROOT}/etc/lighttpd.conf ]] ; then
+ elog
+ elog "Gentoo has a customized configuration,"
+ elog "which is now located in ${EROOT}/etc/lighttpd. Please migrate your"
+ elog "existing configuration."
+ fi
+
+ if use brotli || use zstd || use zlib ; then
+ elog
+ elog "Remember to clean your cache directory when using"
+ elog "output compression!"
+ elog "https://wiki.lighttpd.net/Docs_ModDeflate"
+ fi
+
+ if use mysql ; then
+ elog
+ elog "Note that upstream has moved away from using mysql directly"
+ elog "via mod_mysql and is now accessing it through mod_dbi. You"
+ elog "may need to update your configuration"
+ fi
+
+ elog
+ elog "Upstream has deprecated a number of features. They are not missing"
+ elog "but have been migrated to other mechanisms. Please see upstream"
+ elog "changelog for details."
+ elog "https://www.lighttpd.net/2022/1/19/1.4.64/"
+}
diff --git a/www-servers/puma/Manifest b/www-servers/puma/Manifest
index 202572679adf..13d952c238da 100644
--- a/www-servers/puma/Manifest
+++ b/www-servers/puma/Manifest
@@ -4,9 +4,11 @@ DIST puma-5.6.5.tar.gz 314953 BLAKE2B 2aca92ff3d32995be8f05b626c2299c07f8665f345
DIST puma-6.0.0.tar.gz 345407 BLAKE2B eb7b1c44e04249441dd9c3084cb4a7965216fe31d3d851026e0548f91dc5d20355e2635d54a062a9c32622ee0b21ba64669b2c905976e2cae83e8fdb7a153616 SHA512 2b5b31e315fc4b5f8f510e7e08941100835c9ab33007569da178eeca0c729ac45955146b85294792d89b7a13168fbb9173a2c55c38e1cd1e10fa243c30966be3
DIST puma-6.0.1.tar.gz 348199 BLAKE2B 5f27b6e1e688d875b90420382afe75c6aced0010bc89b9a526c9cc47d14cefc1171e6fc19f13596d127294842a85f4456a5cd8c65d9382aa60c39b72a7d16a6c SHA512 e5025613a23c3677caf120486e1e8072be0ddc61752706cfbda26abd4fa3e0e3c1e80ce3999bc90a6e3d75482ca129a842a7a9765537d1dc88d14bf61556618b
DIST puma-6.0.2.tar.gz 348269 BLAKE2B b0bf0efe179e78259b7b9f5ed8b2a701829ae4619edff00975a7a7e21eefd6560d051957d47fc2f5a4ba10cc2c8bcc863d4340f640054b8f081a7aa7fdbf8ede SHA512 9202ff3767a5944558a34904e58db3c0c0dd9e68df1ebcc76f31fbccea90edcd0f2d60360bd7bbd517eb965be4b1a99faf31ed0a0c36a41c13e8b0573c40f530
+DIST puma-6.1.0.tar.gz 355394 BLAKE2B 664bd24be4afde93c7fb3c6b407f0fd943bcebd86ec183d6f6d965c194f1b111d460b044eb64bcbaaff743a2d24031f786fb340a9e4ae624f324c2b70273723d SHA512 642755f565d6f1f2baebac041112dad238ca2b815f85c5653cf913c0c007e9971212581036f48fa9bdcfe98b28261843ab80306ed693274c77849bce012125f3
EBUILD puma-5.6.4.ebuild 1921 BLAKE2B 45b9df162d968af84748364e3f3d6b00964c017b35805a202b6b712c79411234ffbc503b7d68b9c3618811e252598ef84857ca01b2a5b8a5c6da0018168ef0dc SHA512 c6163f0b264d25cfbfa08cb9e9bb7b6c061c1dacddbc990b383e1db05e0c77e892fdd13c98e7f9c4e89e31fdc8119dcd641c2ddc7576cad92f0f1a5c050fd3cb
EBUILD puma-5.6.5.ebuild 1861 BLAKE2B 9fccd5ac7b24e5de70a7684621895ab5a0033c65d08a0879b831cb527696d3cdc65ffec4b8867b27b85fc3d66813b2e68594d9ef47f7bc90d9d8d447c0c5aa75 SHA512 d8a8f5a37c984531326b907dddca82514790637e9778d4c1c5d0adebf3bb3fbd49b3a17796888c349e1d0fa0e5de336e2b9310f368ea6fd02f0ab70e09badd1d
EBUILD puma-6.0.0.ebuild 1890 BLAKE2B 701c88a61bbe44e2b72fce75921043036f3defe7fb66dd28a34afb42574a5bc05cc8d410903121a404be3b359cae9bde25ec7a59bbf447cf7ab6a51068ec1b1d SHA512 f8b81ac9e7432339cd8c0297ee4271eb4b67e74feaff9a999c70baa895a4fdc90355a5397db02c8b7b44a7d4fbc1d7c89dba02824a144183a01da2d5c89e15a7
EBUILD puma-6.0.1.ebuild 1890 BLAKE2B 701c88a61bbe44e2b72fce75921043036f3defe7fb66dd28a34afb42574a5bc05cc8d410903121a404be3b359cae9bde25ec7a59bbf447cf7ab6a51068ec1b1d SHA512 f8b81ac9e7432339cd8c0297ee4271eb4b67e74feaff9a999c70baa895a4fdc90355a5397db02c8b7b44a7d4fbc1d7c89dba02824a144183a01da2d5c89e15a7
EBUILD puma-6.0.2.ebuild 1890 BLAKE2B 157dae5ba217a3d4814b9ef1e3c08e633d04d48970783c3446cef4ac5497d0f0150630c4607ec6479a9d45e3e4e1880793084fc04189c6e258a5f30862265cb8 SHA512 a541171cb753ff342604bef4a460b969d74ba3751c3c57a62a0b5de87ef07acd1821226411bcd6e889ea6ece386ad687ec0e675465eb957e05d2d08001d2e486
+EBUILD puma-6.1.0.ebuild 1932 BLAKE2B 9e29e12283d4b906c4c1876719463f1a1379852bfddb4193a1983dd7376b664fa4bf6965a2cf3984dab011418ae33c33d2a582472b9a583c3d48b3fa3ae11549 SHA512 e9723db022c6a926fd02dba8ac760845d1ab475eb5eb4a999c24f87e92b9baa9b852d8976d14012dc9874bdd1138c225f72e4eef59cdb825efef4658b5d7ef0f
MISC metadata.xml 710 BLAKE2B bf109653812999e453fb414a83bf404786d16df301ba9dff87c123e0f1dbff8e3024109e96b7f36a3d9e1ebe57eb7aecc7acfd923f0de1bc8c4f358a87b32379 SHA512 894c677c61b3c7f8081b1511c64c274497c4ea85171f5b19d9606a19e4dff33df00d169653e3aede3eee07737b1cf9faadb812eebcf67292be68150c026b7f8e
diff --git a/www-servers/puma/puma-6.1.0.ebuild b/www-servers/puma/puma-6.1.0.ebuild
new file mode 100644
index 000000000000..72c9b91a9b12
--- /dev/null
+++ b/www-servers/puma/puma-6.1.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_GEMSPEC="puma.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/puma_http11/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR=lib/puma
+
+inherit ruby-fakegem
+
+DESCRIPTION="a simple, fast, threaded, and highly concurrent HTTP 1.1 server for Ruby/Rack"
+HOMEPAGE="https://puma.io/"
+SRC_URI="https://github.com/puma/puma/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+DEPEND+=" dev-libs/openssl:0 test? ( net-misc/curl )"
+RDEPEND+=" dev-libs/openssl:0="
+
+ruby_add_bdepend "virtual/ruby-ssl
+ test? ( dev-ruby/localhost dev-ruby/rack:2.2 >=dev-ruby/minitest-5.9:5 >=dev-ruby/test-unit-3.0:2 )"
+
+ruby_add_rdepend "dev-ruby/nio4r:2"
+
+all_ruby_prepare() {
+ sed -e '/bundler/ s:^:#:' \
+ -e '/prove/ s:^:#:' \
+ -e '/stub_const/ s:^:#:' \
+ -i test/helper.rb || die
+
+ # Avoid tests failing inconsistently
+ sed -i -e '/test_bad_client/askip "inconsistent results"' test/test_web_server.rb || die
+
+ # Avoid launcher tests since they make assumptions about bundler use
+ rm -f test/test_launcher.rb test/test_worker_gem_independence.rb test/test_bundle_pruner.rb || die
+
+ # Skip integration tests since they make a lot of assumptions about
+ # the environment
+ rm -f test/test_integration_* test/test_preserve_bundler_env.rb|| die
+
+ # Avoid test that uses unpackaged stub_const
+ sed -i -e '/test_shutdown_with_grace/,/^ end/ s:^:#:' test/test_thread_pool.rb || die
+
+ sed -e 's/git ls-files --/find/' \
+ -e 's:_relative ": "./:' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ einfo "Running test suite"
+ PUMA_CI_RACK_2=true ${RUBY} -Ilib:.:test -e "gem 'minitest', '~>5.9'; gem 'test-unit', '~>3.0'; gem 'rack', '<3'; require 'minitest/autorun'; Dir['test/**/*test_*.rb'].each{|f| require f}" || die
+}