summaryrefslogtreecommitdiff
path: root/www-servers/tornado/tornado-4.4.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/tornado/tornado-4.4.2-r1.ebuild')
-rw-r--r--www-servers/tornado/tornado-4.4.2-r1.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/www-servers/tornado/tornado-4.4.2-r1.ebuild b/www-servers/tornado/tornado-4.4.2-r1.ebuild
deleted file mode 100644
index 415ca7a33c42..000000000000
--- a/www-servers/tornado/tornado-4.4.2-r1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_6 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Python web framework and asynchronous networking library"
-HOMEPAGE="http://www.tornadoweb.org/ https://pypi.org/project/tornado/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
- dev-python/certifi[${PYTHON_USEDEP}]
- >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7')
- || (
- >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
- ( $(python_gen_cond_dep 'dev-python/twisted-names[${PYTHON_USEDEP}]' 'python2_7')
- $(python_gen_cond_dep 'dev-python/twisted-web[${PYTHON_USEDEP}]' 'python2_7')
- )
- )
- virtual/python-backports_abc[${PYTHON_USEDEP}]
- virtual/python-futures[${PYTHON_USEDEP}]
- virtual/python-singledispatch[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- )
- test? (
- ${CDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="${CDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/4.4-drop-intersphinx.patch
- "${FILESDIR}"/4.4.1-options-test.patch
-)
-
-python_compile_all() {
- use doc && emake -C docs sphinx
-}
-
-python_test() {
- "${PYTHON}" -m tornado.test.runtests || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r demos/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-}