summaryrefslogtreecommitdiff
path: root/www-servers/gunicorn/gunicorn-19.9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/gunicorn/gunicorn-19.9.0.ebuild')
-rw-r--r--www-servers/gunicorn/gunicorn-19.9.0.ebuild19
1 files changed, 5 insertions, 14 deletions
diff --git a/www-servers/gunicorn/gunicorn-19.9.0.ebuild b/www-servers/gunicorn/gunicorn-19.9.0.ebuild
index c98e3a00bb6f..34f357fed9df 100644
--- a/www-servers/gunicorn/gunicorn-19.9.0.ebuild
+++ b/www-servers/gunicorn/gunicorn-19.9.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
inherit distutils-r1
@@ -13,13 +13,12 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT PSF-2 doc? ( BSD )"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="doc test"
+IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
@@ -29,22 +28,14 @@ DEPEND="
DOCS="README.rst"
-python_prepare_all() {
- sed -ie "s/..\/bin/\/usr\/bin\//" docs/Makefile || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
+distutils_enable_sphinx 'docs/source' --no-autodoc
python_test() {
py.test -v || die "Testing failed with ${EPYTHON}"
}
python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
+ use doc && local HTML_DOCS=( docs/source/_build/html/. )
distutils-r1_python_install_all
}