summaryrefslogtreecommitdiff
path: root/www-servers/gatling
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/gatling')
-rw-r--r--www-servers/gatling/Manifest2
-rw-r--r--www-servers/gatling/files/gatling.initd63
-rw-r--r--www-servers/gatling/files/gatling.initd-263
3 files changed, 0 insertions, 128 deletions
diff --git a/www-servers/gatling/Manifest b/www-servers/gatling/Manifest
index a14283f3a338..63c87a3d5254 100644
--- a/www-servers/gatling/Manifest
+++ b/www-servers/gatling/Manifest
@@ -1,7 +1,5 @@
AUX gatling-0.13-compile.patch 255 BLAKE2B 08de101796184625542dd339b96e246477a0cb8aaa40bac8640f0d442b9fba09389ada09bd4f852736487bfda30915f0ca562e1ea6aed0bee8d0104cb65a9c63 SHA512 77e35689b80a4d1b9598bf31cc14c3572a7b92d49ffeb98442552f58eeb04a196ce5c8215941d07e197191c349548d23baadac3b84854d6eb93d26632555c699
AUX gatling.confd 659 BLAKE2B ac3a2bc798e8ee9172f7c807c7e80f5bc7ad12e1830f296f097078887e609facfcb6087c6d5cdaa162fd747d7f03d208a28ec30e12fb67e7dc938ed0e65f766b SHA512 e903cd9afbb575226c6de0da8ad673d4650a53cac7442505422c98c32a00457f3d48f2853355cd76ea0f83671cb973ddf90df900d86a15172291317109481fb3
-AUX gatling.initd 1915 BLAKE2B 8f0954d855759b6abe90d6ea823fb2e14bddcc36d45a20bbb731aaeb0a4efa2b3bfdc454d9ae1c127634057a33032dd73086d6f7f8c99678bf79c6bf602bcc19 SHA512 7992a44fc61408eef740bd94fd127240b85a27954c6217b44e7be01a6b95256acc8f61962b661eaeecd6321b958403430aae673b9e88656bb11883b577a3d9a6
-AUX gatling.initd-2 1970 BLAKE2B 6c964b6fba4bf576efbbf659fc027b336fe82ada1f822242fd62964dfb64efb71af4adda687bb406b78234b4a01ac6bd0e419e5a7d638b42c7833515e78b1996 SHA512 916b19712c51564bb38167262de1358289202894b80b948c1d10463c74fea0de9bcddc33a8dd804a08f5a07d1762e0cd21bfe6a404dbfe3fd49138248384dbfc
AUX gatling.initd-3 1970 BLAKE2B ba48e796b4fca2cd165756b3ef781feb47be18e43043d834e028d80b522f1fe6482db79bb89a7a7e57c1fdd80f6cdbb525ec0153af8600daf848d7408aa4ff6e SHA512 3b198ed6728add5f30e8ec16171cc7086d315448821b3a5487be1cf7b318735a77f0881d9aca0a5af179a2b8aff75fd0c0ce80836172a26c439cba2859c6ab1f
DIST gatling-0.15.tar.xz 121804 BLAKE2B 7df5f6d4fc823e8a1252bacca2b57d0848dd3a920216d1d3185d5f471f786eee1eb36396114b367660ead816bd4ee6c734099bbb9bdb5ffbd5b70a59e0fb0667 SHA512 b76d220a0644f1e6e7ea966a4eff409964c564fc4a31c4efdb764e5f7b5857bc58c26bc31e860fe35df932cbd60fb2b0f4f21c75cb5aa56427e8a2a453684716
EBUILD gatling-0.15.ebuild 1309 BLAKE2B c70f35d0d7ec361cb2c69eea8e6372e839c86e91242e2eb347534917d390c5131000fe601c8541486a9ea918508680152dd2e387a9f1738985a35731ebd80e07 SHA512 6269217a4998b6684ea2cb2a7a31c1784f57c214ad6b141ce2664071e50bc38128fc6a809692b5a28e20b28a6c11ba26812b07a50a7da854ab02f1a40e728c7b
diff --git a/www-servers/gatling/files/gatling.initd b/www-servers/gatling/files/gatling.initd
deleted file mode 100644
index fadb1ce9d175..000000000000
--- a/www-servers/gatling/files/gatling.initd
+++ /dev/null
@@ -1,63 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-description="Gatling high performance web server init script"
-opts="reload"
-
-depend() {
- need net
-}
-
-checkconfig() {
- # Verify UID is valid for running process.
- if [[ ! $(id ${GATLING_UID} 2>/dev/null) ]]; then
- ewarn "User ${GATLING_UID} not found!"
- return 1
- fi
-
- # Set gatling run opts
- if yesno ${VHOST};then VHOST=-v;else VHOST=-V;fi
- if yesno ${SSL};then SSL=-e;else SSL=-E;fi
- if yesno ${DIR_INDEXING};then DIR_INDEXING=-d;else DIR_INDEXING=-D;fi
- if yesno ${FTP}; then FTP=-f;else FTP=-F;fi
- if yesno ${FTP_AUTH}; then FTP_AUTH=-l;else unset FTP_AUTH;fi
- if yesno ${FTP_UP};then unset FTP_UP;else FTP_UP=-U;fi
- yesno ${TRANS_PROXY} && TRANS_PROXY=-t
-}
-
-start() {
- checkconfig || return 1
-
- ebegin "Starting gatling"
- start-stop-daemon --start --quiet --background --make-pidfile --pidfile ${PID} \
---name gatling --exec /usr/bin/gatling -- -T ${HTTP_TIMEOUT} -i ${IP} -p ${PORT} -P ${PREFETCH} \
-${VHOST} -c ${ROOTDIR} ${DIR_INDEXING} ${TRANS_PROXY} -u ${GATLING_UID} ${FTP} -T ${FTP_TIMEOUT} \
-${FTP_AUTH} ${FTP_UPLOADS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping gatling"
- start-stop-daemon --quiet --stop --pidfile ${PID}
- eend $?
-}
-
-reload() {
- if ! service_started "${SVCNAME}" ; then
- eerror "${SVCNAME} isn't running"
- return 1
- fi
-
- checkconfig || return 1
-
- ebegin "Sending gatling the HUP signal"
- start-stop-daemon --quiet --signal HUP --pidfile ${PID}
-
- ebegin "Restarting gatling server"
- start-stop-daemon --start --quiet --background --make-pidfile --pidfile ${PID} \
---name gatling --exec /usr/bin/gatling -- -T ${HTTP_TIMEOUT} -i ${IP} -p ${PORT} -P ${PREFETCH} \
-${VHOST} -c ${ROOTDIR} ${DIR_INDEXING} ${TRANS_PROXY} -u ${GATLING_UID} ${FTP} -T ${FTP_TIMEOUT} \
-${FTP_AUTH} ${FTP_UPLOADS}
- eend $?
-}
diff --git a/www-servers/gatling/files/gatling.initd-2 b/www-servers/gatling/files/gatling.initd-2
deleted file mode 100644
index 77f436009b34..000000000000
--- a/www-servers/gatling/files/gatling.initd-2
+++ /dev/null
@@ -1,63 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-description="Gatling high performance web server init script"
-extra_started_commands="reload"
-
-depend() {
- need net
-}
-
-checkconfig() {
- # Verify UID is valid for running process.
- if [[ ! $(id ${GATLING_UID} 2>/dev/null) ]]; then
- ewarn "User ${GATLING_UID} not found!"
- return 1
- fi
-
- # Set gatling run opts
- if yesno ${VHOST};then VHOST=-v;else VHOST=-V;fi
- if yesno ${SSL};then SSL=-e;else SSL=-E;fi
- if yesno ${DIR_INDEXING};then DIR_INDEXING=-d;else DIR_INDEXING=-D;fi
- if yesno ${FTP}; then FTP=-f;else FTP=-F;fi
- if yesno ${FTP_AUTH}; then FTP_AUTH=-l;else unset FTP_AUTH;fi
- if yesno ${FTP_UP};then unset FTP_UP;else FTP_UP=-U;fi
- if yesno ${TRANS_PROXY};then TRANS_PROXY=-t;else unset TRANS_PROXY;fi
-}
-
-start() {
- checkconfig || return 1
-
- ebegin "Starting gatling"
- start-stop-daemon --start --quiet --background --make-pidfile --pidfile ${PID} \
---name gatling --exec /usr/bin/gatling -- -T ${HTTP_TIMEOUT} -i ${IP} -p ${PORT} -P ${PREFETCH} \
-${VHOST} -c ${ROOTDIR} ${DIR_INDEXING} ${TRANS_PROXY} -u ${GATLING_UID} ${FTP} -T ${FTP_TIMEOUT} \
-${FTP_AUTH} ${FTP_UPLOADS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping gatling"
- start-stop-daemon --quiet --stop --pidfile ${PID}
- eend $?
-}
-
-reload() {
- if ! service_started "${SVCNAME}" ; then
- eerror "${SVCNAME} isn't running"
- return 1
- fi
-
- checkconfig || return 1
-
- ebegin "Sending gatling the HUP signal"
- start-stop-daemon --quiet --signal HUP --pidfile ${PID}
-
- ebegin "Restarting gatling server"
- start-stop-daemon --start --quiet --background --make-pidfile --pidfile ${PID} \
---name gatling --exec /usr/bin/gatling -- -T ${HTTP_TIMEOUT} -i ${IP} -p ${PORT} -P ${PREFETCH} \
-${VHOST} -c ${ROOTDIR} ${DIR_INDEXING} ${TRANS_PROXY} -u ${GATLING_UID} ${FTP} -T ${FTP_TIMEOUT} \
-${FTP_AUTH} ${FTP_UPLOADS}
- eend $?
-}