summaryrefslogtreecommitdiff
path: root/www-plugins/lightspark
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins/lightspark')
-rw-r--r--www-plugins/lightspark/Manifest2
-rw-r--r--www-plugins/lightspark/lightspark-0.8.5.ebuild94
2 files changed, 0 insertions, 96 deletions
diff --git a/www-plugins/lightspark/Manifest b/www-plugins/lightspark/Manifest
index 12ca6e4ee86d..9bb87936aaf1 100644
--- a/www-plugins/lightspark/Manifest
+++ b/www-plugins/lightspark/Manifest
@@ -1,5 +1,3 @@
-DIST lightspark-0.8.5.tar.gz 2490510 BLAKE2B 33966bd811a311ee1cc6c59517f17933c73da926ea40485800076c26eea3ddec29f18fffff12d1fd8c36f43c932ac56128b483a9dc104f006b3a1805992f0aa4 SHA512 79e78925f9132b2c6044e4abf326d768c8d45509f85d9123e3dd172b2769772567223676fa7c8ea4d08bc541e9aa7a2b2d5a1062ff9f3a6274234af8798ee11b
DIST lightspark-0.8.6.1.tar.gz 5419194 BLAKE2B dfe56f604c6dd9f9848c1cedffce5bc2a20f51a8b42405f5a38ddbc5c5a1db87e69cba99f5045cd7f60957e46992da8442d95d7ef929bcb806ed5ab0a17f084e SHA512 ea54b3d66acfcb12aac271669d550f6aa1709db59d4bcc005479b7be394a4ca30473a993a780c632228eeaad2977d97cdbcadff5cf8abbbf07503f9d56192f31
-EBUILD lightspark-0.8.5.ebuild 2522 BLAKE2B e3d712eb47f22a3352a5a95363745335f7006d90efdafa93fa82d839d1560da90bcda3873b9d8cbb6de7fb4a83a3d39c1eebb3e0e35d306e944ec58a5315c509 SHA512 4bfb3f005bede7a52bb2ced7818dee942dc79cc9e62dbd9183cb8be52b256d859d5df75e41ff8228914bd1e0d27938231584cdfce8cdb60cf23c2be692e130ef
EBUILD lightspark-0.8.6.1.ebuild 2498 BLAKE2B 7b1850205941a6424fa80fe22c7ceb80e44acbd4d840de2f7e0efa3067efd81c80f5c85a5fc684cb40cf6bae1020d167c696252141b72a1a536533ff60d5abe0 SHA512 c483d090fef31956943a4d632ad311c25f021ffbcbe8a6c576e7586546da40ac396555e6875e622a47e5c62d9d4238cff37df6790e47acaff55519b5690b3b7d
MISC metadata.xml 729 BLAKE2B c6709bbbb2b685aec70f81c095b30f1c7acb65847c409d67131a733fcdafbd908b72c17b8acd60ee93707ac1bc4f38c0267778bdf346d910e4ba9cd521cd6714 SHA512 a1db1257f8102dc502ee0d275982ae94c5ed11419689066ee9f403df642831a1e2dd3d386d120c21ba74e59050e34f44b69e4dc381cc29136b3b3d7197589b64
diff --git a/www-plugins/lightspark/lightspark-0.8.5.ebuild b/www-plugins/lightspark/lightspark-0.8.5.ebuild
deleted file mode 100644
index dd32cad0dd75..000000000000
--- a/www-plugins/lightspark/lightspark-0.8.5.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit cmake toolchain-funcs xdg-utils
-
-DESCRIPTION="High performance flash player"
-HOMEPAGE="https://lightspark.github.io/"
-SRC_URI="
- https://github.com/lightspark/lightspark/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
-S=${WORKDIR}/${P/_rc*/}
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="cpu_flags_x86_sse2 curl ffmpeg gles2-only nsplugin ppapi profile rtmp"
-
-# Note: no LLVM since it's broken upstream
-RDEPEND="app-arch/xz-utils:0=
- dev-libs/glib:2=
- dev-libs/libpcre:3=[cxx]
- media-fonts/liberation-fonts
- media-libs/freetype:2=
- media-libs/libpng:0=
- media-libs/libsdl2:0=
- media-libs/sdl2-mixer:0=
- sys-libs/zlib:0=
- x11-libs/cairo:0=
- x11-libs/libX11:0=
- x11-libs/pango:0=
- virtual/jpeg:0=
- curl? ( net-misc/curl:0= )
- ffmpeg? ( media-video/ffmpeg:0= )
- gles2-only? ( media-libs/mesa:0=[gles2] )
- !gles2-only? (
- >=media-libs/glew-1.5.3:0=
- virtual/opengl:0=
- )
- rtmp? ( media-video/rtmpdump:0= )"
-DEPEND="${RDEPEND}"
-BDEPEND="
- amd64? ( dev-lang/nasm )
- x86? ( dev-lang/nasm )
- virtual/pkgconfig"
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_CURL=$(usex curl)
- -DENABLE_GLES2=$(usex gles2-only)
- -DENABLE_LIBAVCODEC=$(usex ffmpeg)
- -DENABLE_RTMP=$(usex rtmp)
-
- -DENABLE_MEMORY_USAGE_PROFILING=$(usex profile)
- -DENABLE_PROFILING=$(usex profile)
- -DENABLE_SSE2=$(usex cpu_flags_x86_sse2)
-
- -DCOMPILE_NPAPI_PLUGIN=$(usex nsplugin)
- -DPLUGIN_DIRECTORY="${EPREFIX}"/usr/$(get_libdir)/${PN}/plugins
- # TODO: install /etc/chromium file? block adobe-flash?
- -DCOMPILE_PPAPI_PLUGIN=$(usex ppapi)
- -DPPAPI_PLUGIN_DIRECTORY="${EPREFIX}"/usr/$(get_libdir)/chromium-browser/${PN}
- )
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- if use nsplugin; then
- # copied from nsplugins.eclass, that's broken in EAPI 7
- dodir /usr/$(get_libdir)/nsbrowser/plugins
- dosym ../../lightspark/plugins/liblightsparkplugin.so \
- /usr/$(get_libdir)/nsbrowser/plugins/liblightsparkplugin.so
- fi
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-
- if use nsplugin && has_version "www-plugins/gnash[nsplugin]"; then
- elog "Having two plugins installed for the same MIME type may confuse"
- elog "Mozilla based browsers. It is recommended to disable the nsplugin"
- elog "USE flag for either gnash or lightspark. For details, see"
- elog "https://bugzilla.mozilla.org/show_bug.cgi?id=581848"
- fi
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-}