summaryrefslogtreecommitdiff
path: root/www-misc
diff options
context:
space:
mode:
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/Manifest.gzbin2585 -> 2585 bytes
-rw-r--r--www-misc/urlwatch/Manifest2
-rw-r--r--www-misc/urlwatch/urlwatch-2.29.ebuild72
3 files changed, 74 insertions, 0 deletions
diff --git a/www-misc/Manifest.gz b/www-misc/Manifest.gz
index dcf62d753fd9..8375b99ebeef 100644
--- a/www-misc/Manifest.gz
+++ b/www-misc/Manifest.gz
Binary files differ
diff --git a/www-misc/urlwatch/Manifest b/www-misc/urlwatch/Manifest
index 1bb38d33905d..664e6dde88b8 100644
--- a/www-misc/urlwatch/Manifest
+++ b/www-misc/urlwatch/Manifest
@@ -1,4 +1,6 @@
AUX urlwatch-2.28-lxml-5.patch 1520 BLAKE2B ecbf31376f8cdd1d6a68d70ea1ef4d20985a4a79c22740e66c50edf0d7039261492544526c6ed41d1515eafe0325797653ca7da40b8e2a7ae85cbc822a2b04d7 SHA512 b5ebf699069833e3cf1d1bdbddd0307f705b0391571bbfe1f80a7c6b9464216facbe87c9b5a53141ed24c71b3d210aebcce8fed636b584e357d01086de5f2a35
DIST urlwatch-2.28.tar.gz 306929 BLAKE2B 73fcff8c153db472c944d0c9406e0e98bf64299d5532486a08cb024339544f17d716a22d6f0807ba55c79af9dc7fef41fa8dc5a7fe79c831f3e9958e3ea8958e SHA512 21a662006dc92c0c636ef0beebc4f2ec90b82182aa0ba94a3348026c2c001b6d74198a14c198f681c8e773b640b6030b63de1a081984ea4d1bbc1e2648bc4161
+DIST urlwatch-2.29.tar.gz 180540 BLAKE2B 69a86d208cb5e69f2596006d901696da92d8640119d1b3bcfdc31ba7ce196b5558a10266da5b320f813912fc564fa1550db9011217ead4c13f55ebe2755fc7b5 SHA512 09a8f1e7133614d6dfab9b7fdf56006ee6d2144bcaa8079a9bd9d8222fd67a08ab094c26956f01432bd9148fa5d1017607031673a02333ba5eac1060a2571c87
EBUILD urlwatch-2.28-r1.ebuild 2075 BLAKE2B adc01714b6b716d94b996716e5ee09d0ffa2337deeaae112ddf6ff28c8ec780748c8a299a9ef51aa1e1782848531a2fa4e1a1a650ed07c29fef9e1a734afe674 SHA512 39c82fbaab875cde1b34c6a4a7a8c1c1f89383748789b6dc06624d418c9b767bc4584cdf96ac2ed2ba037824ca18b7f44b886751d5009b6b724a224345fb5fe7
+EBUILD urlwatch-2.29.ebuild 2036 BLAKE2B e0c029db1b5a938b2055650f767c5a6782d008f27cc014a582e531b9f958328ad1241b4a90e17d0b3866baa42cd0e6ad557d297ed8591140898ea4e3838a9342 SHA512 6f89abe29a676dbcc1e22748497bbebc96e7cfdf6cf6670b7f72e6e59658ddfadc15c8d53edf8cfc58b9556c9fda4112649552b29468a8a440c4fab7f57dc445
MISC metadata.xml 429 BLAKE2B d57e7a49e9ad6a0ff190b49ea3a4b952fc7198d4194c6084eb9f25c04ede497b9f26d85286e112587bbccc545704d724c769177bac606fe9f72bcceaa696ea95 SHA512 07c77e3b4fade823134c6252c65e30eeca4800283db5300b12c84c7d7aa5d734c27363748d5f2702be506847ff53501ccd2ee3fcc312f77ca6b78c2a9c9691e1
diff --git a/www-misc/urlwatch/urlwatch-2.29.ebuild b/www-misc/urlwatch/urlwatch-2.29.ebuild
new file mode 100644
index 000000000000..44b99aa93824
--- /dev/null
+++ b/www-misc/urlwatch/urlwatch-2.29.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A tool for monitoring webpages for updates"
+HOMEPAGE="
+ https://thp.io/2008/urlwatch/
+ https://github.com/thp/urlwatch/
+ https://pypi.org/project/urlwatch/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ >=dev-python/minidb-2.0.8[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ app-text/tesseract[png]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jq[${PYTHON_USEDEP}]
+ dev-python/pytesseract[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_sphinx docs/source dev-python/alabaster
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Require the pdftotext module
+ "lib/urlwatch/tests/test_filter_documentation.py::test_url[https://example.net/pdf-test.pdf]"
+ "lib/urlwatch/tests/test_filter_documentation.py::test_url[https://example.net/pdf-test-password.pdf]"
+ # Skip code quality check
+ "lib/urlwatch/tests/test_handler.py::test_pep8_conformance"
+)
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ if ! has_version dev-python/chump; then
+ elog "Install 'dev-python/chump' to enable Pushover" \
+ "notifications support"
+ fi
+ if ! has_version dev-python/jq; then
+ elog "Install 'dev-python/jq' to enable jq filtering support"
+ fi
+ if ! has_version dev-python/pytesseract; then
+ elog "Install 'dev-python/pytesseract' to enable OCR support"
+ fi
+ elog "HTML parsing can be improved by installing one of the following packages"
+ elog "and changing the html2text subfilter parameter:"
+ elog "dev-python/beautifulsoup4"
+ elog "app-text/html2text"
+ elog "dev-python/html2text"
+ elog "www-client/lynx"
+ fi
+}