summaryrefslogtreecommitdiff
path: root/www-misc/wsmake/wsmake-0.6.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-misc/wsmake/wsmake-0.6.4-r1.ebuild')
-rw-r--r--www-misc/wsmake/wsmake-0.6.4-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/www-misc/wsmake/wsmake-0.6.4-r1.ebuild b/www-misc/wsmake/wsmake-0.6.4-r1.ebuild
new file mode 100644
index 000000000000..69070d300913
--- /dev/null
+++ b/www-misc/wsmake/wsmake-0.6.4-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Website pre-processor features tag substitution and page ordering"
+HOMEPAGE="https://sourceforge.net/projects/wsmake/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ Artistic"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="examples"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-bv.diff
+ "${FILESDIR}"/${P}-gcc43.patch # 251745
+ "${FILESDIR}"/${P}-fix-const-va_list.patch
+)
+
+src_unpack() {
+ default
+
+ cd "${S}"/doc || die
+ tar -cf examples.tar examples || die
+}
+
+src_configure() {
+ tc-export CXX
+ default
+}
+
+src_install() {
+ default
+ dodoc doc/manual.txt
+
+ if use examples; then
+ rm -r doc/examples/CVS || die
+ dodoc -r doc/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}