summaryrefslogtreecommitdiff
path: root/www-misc/fcgiwrap/fcgiwrap-1.1.0_pre20150419.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-misc/fcgiwrap/fcgiwrap-1.1.0_pre20150419.ebuild')
-rw-r--r--www-misc/fcgiwrap/fcgiwrap-1.1.0_pre20150419.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/www-misc/fcgiwrap/fcgiwrap-1.1.0_pre20150419.ebuild b/www-misc/fcgiwrap/fcgiwrap-1.1.0_pre20150419.ebuild
deleted file mode 100644
index b6310e79a9d5..000000000000
--- a/www-misc/fcgiwrap/fcgiwrap-1.1.0_pre20150419.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-[[ ${PV} = *9999* ]] && VCS_ECLASS="git-r3" || VCS_ECLASS=""
-inherit autotools systemd toolchain-funcs ${VCS_ECLASS}
-
-DESCRIPTION="Simple FastCGI wrapper for CGI scripts (CGI support for nginx)"
-HOMEPAGE="https://github.com/gnosek/fcgiwrap"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="systemd"
-
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/gnosek/${PN}.git"
-else
- MY_REV="99c942c90063c73734e56bacaa65f947772d9186"
- MY_P="gnosek-fcgiwrap-${MY_REV:0:7}"
- SRC_URI="https://github.com/gnosek/${PN}/tarball/${MY_REV} -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-
-RDEPEND="
- dev-libs/fcgi
- systemd? ( sys-apps/systemd )
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-DOCS=( README.rst )
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- sed -e "s/-Werror//" \
- -i configure.ac || die "sed failed"
-
- sed -e '/man8dir = $(DESTDIR)/s/@prefix@//' \
- -i Makefile.in || die "sed failed"
-
- sed -e "s/libsystemd-daemon/libsystemd/" \
- -i configure.ac || die "sed failed"
- tc-export CC
-
- # Fix systemd units for Gentoo
- sed -i -e '/User/d' systemd/fcgiwrap.service || die
- sed -i -e '/Group/d' systemd/fcgiwrap.service || die
-
- eapply_user
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_with systemd) \
- --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
-}
-
-pkg_postinst() {
- einfo 'You may want to install www-servers/spawn-fcgi to use with fcgiwrap.'
-}