summaryrefslogtreecommitdiff
path: root/www-client/seamonkey/files
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/seamonkey/files')
-rw-r--r--www-client/seamonkey/files/seamonkey-2.53.7.1-CLEANUP-workaround.patch212
-rw-r--r--www-client/seamonkey/files/seamonkey-2.53.7.1-cpu_hog_fix.patch72
-rw-r--r--www-client/seamonkey/files/seamonkey-2.53.7.1-rust-1.52.patch52
3 files changed, 0 insertions, 336 deletions
diff --git a/www-client/seamonkey/files/seamonkey-2.53.7.1-CLEANUP-workaround.patch b/www-client/seamonkey/files/seamonkey-2.53.7.1-CLEANUP-workaround.patch
deleted file mode 100644
index d61341b1e75c..000000000000
--- a/www-client/seamonkey/files/seamonkey-2.53.7.1-CLEANUP-workaround.patch
+++ /dev/null
@@ -1,212 +0,0 @@
---- seamonkey-2.53.7.1/dom/indexedDB/ActorsParent.cpp
-+++ seamonkey-2.53.7.1/dom/indexedDB/ActorsParent.cpp
-@@ -11381,7 +11381,7 @@ AutoSavepoint::~AutoSavepoint()
- MOZ_ASSERT(mDEBUGTransaction->GetMode() == IDBTransaction::READ_WRITE ||
- mDEBUGTransaction->GetMode() ==
- IDBTransaction::READ_WRITE_FLUSH ||
-- mDEBUGTransaction->GetMode() == IDBTransaction::CLEANUP ||
-+ mDEBUGTransaction->GetMode() == IDBTransaction::CLEAN_UP ||
- mDEBUGTransaction->GetMode() == IDBTransaction::VERSION_CHANGE);
-
- if (NS_FAILED(mConnection->RollbackSavepoint())) {
-@@ -11397,7 +11397,7 @@ AutoSavepoint::Start(const TransactionBa
- MOZ_ASSERT(aTransaction);
- MOZ_ASSERT(aTransaction->GetMode() == IDBTransaction::READ_WRITE ||
- aTransaction->GetMode() == IDBTransaction::READ_WRITE_FLUSH ||
-- aTransaction->GetMode() == IDBTransaction::CLEANUP ||
-+ aTransaction->GetMode() == IDBTransaction::CLEAN_UP ||
- aTransaction->GetMode() == IDBTransaction::VERSION_CHANGE);
-
- DatabaseConnection* connection = aTransaction->GetDatabase()->GetConnection();
-@@ -14540,7 +14540,7 @@ Database::AllocPBackgroundIDBTransaction
- if (NS_WARN_IF(aMode != IDBTransaction::READ_ONLY &&
- aMode != IDBTransaction::READ_WRITE &&
- aMode != IDBTransaction::READ_WRITE_FLUSH &&
-- aMode != IDBTransaction::CLEANUP)) {
-+ aMode != IDBTransaction::CLEAN_UP)) {
- ASSERT_UNLESS_FUZZING();
- return nullptr;
- }
-@@ -14549,7 +14549,7 @@ Database::AllocPBackgroundIDBTransaction
- // has write access.
- if (NS_WARN_IF((aMode == IDBTransaction::READ_WRITE ||
- aMode == IDBTransaction::READ_WRITE_FLUSH ||
-- aMode == IDBTransaction::CLEANUP) &&
-+ aMode == IDBTransaction::CLEAN_UP) &&
- mPrincipalInfo.type() == PrincipalInfo::TSystemPrincipalInfo &&
- !mChromeWriteAccessAllowed)) {
- return nullptr;
-@@ -14615,7 +14615,7 @@ Database::RecvPBackgroundIDBTransactionC
- MOZ_ASSERT(aMode == IDBTransaction::READ_ONLY ||
- aMode == IDBTransaction::READ_WRITE ||
- aMode == IDBTransaction::READ_WRITE_FLUSH ||
-- aMode == IDBTransaction::CLEANUP);
-+ aMode == IDBTransaction::CLEAN_UP);
- MOZ_ASSERT(!mClosed);
-
- if (IsInvalidated()) {
-@@ -14778,7 +14778,7 @@ StartTransactionOp::DoDatabaseWork(Datab
-
- Transaction()->SetActiveOnConnectionThread();
-
-- if (Transaction()->GetMode() == IDBTransaction::CLEANUP) {
-+ if (Transaction()->GetMode() == IDBTransaction::CLEAN_UP) {
- nsresult rv = aConnection->DisableQuotaChecks();
- if (NS_WARN_IF(NS_FAILED(rv))) {
- return rv;
-@@ -15097,7 +15097,7 @@ TransactionBase::VerifyRequestParams(con
- case RequestParams::TObjectStoreDeleteParams: {
- if (NS_WARN_IF(mMode != IDBTransaction::READ_WRITE &&
- mMode != IDBTransaction::READ_WRITE_FLUSH &&
-- mMode != IDBTransaction::CLEANUP &&
-+ mMode != IDBTransaction::CLEAN_UP &&
- mMode != IDBTransaction::VERSION_CHANGE)) {
- ASSERT_UNLESS_FUZZING();
- return false;
-@@ -15121,7 +15121,7 @@ TransactionBase::VerifyRequestParams(con
- case RequestParams::TObjectStoreClearParams: {
- if (NS_WARN_IF(mMode != IDBTransaction::READ_WRITE &&
- mMode != IDBTransaction::READ_WRITE_FLUSH &&
-- mMode != IDBTransaction::CLEANUP &&
-+ mMode != IDBTransaction::CLEAN_UP &&
- mMode != IDBTransaction::VERSION_CHANGE)) {
- ASSERT_UNLESS_FUZZING();
- return false;
-@@ -23880,7 +23880,7 @@ CommitOp::WriteAutoIncrementCounts()
- mTransaction->AssertIsOnConnectionThread();
- MOZ_ASSERT(mTransaction->GetMode() == IDBTransaction::READ_WRITE ||
- mTransaction->GetMode() == IDBTransaction::READ_WRITE_FLUSH ||
-- mTransaction->GetMode() == IDBTransaction::CLEANUP ||
-+ mTransaction->GetMode() == IDBTransaction::CLEAN_UP ||
- mTransaction->GetMode() == IDBTransaction::VERSION_CHANGE);
-
- const nsTArray<RefPtr<FullObjectStoreMetadata>>& metadataArray =
-@@ -23948,7 +23948,7 @@ CommitOp::CommitOrRollbackAutoIncrementC
- mTransaction->AssertIsOnConnectionThread();
- MOZ_ASSERT(mTransaction->GetMode() == IDBTransaction::READ_WRITE ||
- mTransaction->GetMode() == IDBTransaction::READ_WRITE_FLUSH ||
-- mTransaction->GetMode() == IDBTransaction::CLEANUP ||
-+ mTransaction->GetMode() == IDBTransaction::CLEAN_UP ||
- mTransaction->GetMode() == IDBTransaction::VERSION_CHANGE);
-
- nsTArray<RefPtr<FullObjectStoreMetadata>>& metadataArray =
-@@ -24080,7 +24080,7 @@ CommitOp::Run()
-
- connection->FinishWriteTransaction();
-
-- if (mTransaction->GetMode() == IDBTransaction::CLEANUP) {
-+ if (mTransaction->GetMode() == IDBTransaction::CLEAN_UP) {
- connection->DoIdleProcessing(/* aNeedsCheckpoint */ true);
-
- connection->EnableQuotaChecks();
---- seamonkey-2.53.7.1/dom/indexedDB/IDBCursor.cpp
-+++ seamonkey-2.53.7.1/dom/indexedDB/IDBCursor.cpp
-@@ -686,7 +686,7 @@ IDBCursor::Update(JSContext* aCx, JS::Ha
- return nullptr;
- }
-
-- if (mTransaction->GetMode() == IDBTransaction::CLEANUP ||
-+ if (mTransaction->GetMode() == IDBTransaction::CLEAN_UP ||
- IsSourceDeleted() ||
- !mHaveValue ||
- mType == Type_ObjectStoreKey ||
---- seamonkey-2.53.7.1/dom/indexedDB/IDBDatabase.cpp
-+++ seamonkey-2.53.7.1/dom/indexedDB/IDBDatabase.cpp
-@@ -673,7 +673,7 @@ IDBDatabase::Transaction(JSContext* aCx,
- break;
- case IDBTransactionMode::Readwrite:
- if (mQuotaExceeded) {
-- mode = IDBTransaction::CLEANUP;
-+ mode = IDBTransaction::CLEAN_UP;
- mQuotaExceeded = false;
- } else {
- mode = IDBTransaction::READ_WRITE;
-@@ -683,7 +683,7 @@ IDBDatabase::Transaction(JSContext* aCx,
- mode = IDBTransaction::READ_WRITE_FLUSH;
- break;
- case IDBTransactionMode::Cleanup:
-- mode = IDBTransaction::CLEANUP;
-+ mode = IDBTransaction::CLEAN_UP;
- mQuotaExceeded = false;
- break;
- case IDBTransactionMode::Versionchange:
-@@ -717,7 +717,7 @@ IDBDatabase::Transaction(JSContext* aCx,
-
- transaction->SetBackgroundActor(actor);
-
-- if (mode == IDBTransaction::CLEANUP) {
-+ if (mode == IDBTransaction::CLEAN_UP) {
- ExpireFileActors(/* aExpireAll */ true);
- }
-
-@@ -870,7 +870,7 @@ IDBDatabase::AbortTransactions(bool aSho
- // We warn for any transactions that could have written data.
- case IDBTransaction::READ_WRITE:
- case IDBTransaction::READ_WRITE_FLUSH:
-- case IDBTransaction::CLEANUP:
-+ case IDBTransaction::CLEAN_UP:
- case IDBTransaction::VERSION_CHANGE:
- transactionsThatNeedWarning.AppendElement(transaction);
- break;
---- seamonkey-2.53.7.1/dom/indexedDB/IDBObjectStore.cpp
-+++ seamonkey-2.53.7.1/dom/indexedDB/IDBObjectStore.cpp
-@@ -1546,7 +1546,7 @@ IDBObjectStore::AddOrPut(JSContext* aCx,
- MOZ_ASSERT(aCx);
- MOZ_ASSERT_IF(aFromCursor, aOverwrite);
-
-- if (mTransaction->GetMode() == IDBTransaction::CLEANUP ||
-+ if (mTransaction->GetMode() == IDBTransaction::CLEAN_UP ||
- mDeletedSpec) {
- aRv.Throw(NS_ERROR_DOM_INDEXEDDB_NOT_ALLOWED_ERR);
- return nullptr;
---- seamonkey-2.53.7.1/dom/indexedDB/IDBTransaction.cpp
-+++ seamonkey-2.53.7.1/dom/indexedDB/IDBTransaction.cpp
-@@ -221,7 +221,7 @@ IDBTransaction::Create(JSContext* aCx, I
- MOZ_ASSERT(aMode == READ_ONLY ||
- aMode == READ_WRITE ||
- aMode == READ_WRITE_FLUSH ||
-- aMode == CLEANUP);
-+ aMode == CLEAN_UP);
-
- RefPtr<IDBTransaction> transaction =
- new IDBTransaction(aDatabase, aObjectStoreNames, aMode);
-@@ -913,7 +913,7 @@ IDBTransaction::GetMode(ErrorResult& aRv
- case READ_WRITE_FLUSH:
- return IDBTransactionMode::Readwriteflush;
-
-- case CLEANUP:
-+ case CLEAN_UP:
- return IDBTransactionMode::Cleanup;
-
- case VERSION_CHANGE:
---- seamonkey-2.53.7.1/dom/indexedDB/IDBTransaction.h
-+++ seamonkey-2.53.7.1/dom/indexedDB/IDBTransaction.h
-@@ -59,7 +59,7 @@ public:
- READ_ONLY = 0,
- READ_WRITE,
- READ_WRITE_FLUSH,
-- CLEANUP,
-+ CLEAN_UP,
- VERSION_CHANGE,
-
- // Only needed for IPC serialization helper, should never be used in code.
-@@ -194,7 +194,7 @@ public:
- AssertIsOnOwningThread();
- return mMode == READ_WRITE ||
- mMode == READ_WRITE_FLUSH ||
-- mMode == CLEANUP ||
-+ mMode == CLEAN_UP ||
- mMode == VERSION_CHANGE;
- }
-
---- seamonkey-2.53.7.1/dom/indexedDB/ProfilerHelpers.h
-+++ seamonkey-2.53.7.1/dom/indexedDB/ProfilerHelpers.h
-@@ -130,7 +130,7 @@ public:
- case IDBTransaction::READ_WRITE_FLUSH:
- AppendLiteral("\"readwriteflush\"");
- break;
-- case IDBTransaction::CLEANUP:
-+ case IDBTransaction::CLEAN_UP:
- AppendLiteral("\"cleanup\"");
- break;
- case IDBTransaction::VERSION_CHANGE:
diff --git a/www-client/seamonkey/files/seamonkey-2.53.7.1-cpu_hog_fix.patch b/www-client/seamonkey/files/seamonkey-2.53.7.1-cpu_hog_fix.patch
deleted file mode 100644
index 51894c485012..000000000000
--- a/www-client/seamonkey/files/seamonkey-2.53.7.1-cpu_hog_fix.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-https://github.com/JustOff/github-wc-polyfill/issues/10
-
---- a/netwerk/protocol/websocket/WebSocketChannel.h
-+++ b/netwerk/protocol/websocket/WebSocketChannel.h
-@@ -151,6 +151,7 @@ private:
- void GeneratePong(uint8_t *payload, uint32_t len);
- void GeneratePing();
-
-+ MOZ_MUST_USE nsresult OnNetworkChangedTargetThread();
- MOZ_MUST_USE nsresult OnNetworkChanged();
- MOZ_MUST_USE nsresult StartPinging();
-
---- a/netwerk/protocol/websocket/WebSocketChannel.cpp
-+++ b/netwerk/protocol/websocket/WebSocketChannel.cpp
-@@ -1270,14 +1270,14 @@ WebSocketChannel::Observe(nsISupports *s
- // Next we check mDataStarted, which we need to do on mTargetThread.
- if (!IsOnTargetThread()) {
- mTargetThread->Dispatch(
-- NewRunnableMethod("net::WebSocketChannel::OnNetworkChanged",
-+ NewRunnableMethod("net::WebSocketChannel::OnNetworkChangedTargetThread",
- this,
-- &WebSocketChannel::OnNetworkChanged),
-+ &WebSocketChannel::OnNetworkChangedTargetThread),
- NS_DISPATCH_NORMAL);
- } else {
-- nsresult rv = OnNetworkChanged();
-+ nsresult rv = OnNetworkChangedTargetThread();
- if (NS_FAILED(rv)) {
-- LOG(("WebSocket: OnNetworkChanged failed (%08" PRIx32 ")",
-+ LOG(("WebSocket: OnNetworkChangedTargetThread failed (%08" PRIx32 ")",
- static_cast<uint32_t>(rv)));
- }
- }
-@@ -1289,23 +1289,25 @@ WebSocketChannel::Observe(nsISupports *s
- }
-
- nsresult
--WebSocketChannel::OnNetworkChanged()
-+WebSocketChannel::OnNetworkChangedTargetThread()
- {
-- if (IsOnTargetThread()) {
-- LOG(("WebSocketChannel::OnNetworkChanged() - on target thread %p", this));
--
-- if (!mDataStarted) {
-- LOG(("WebSocket: data not started yet, no ping needed"));
-- return NS_OK;
-- }
-+ LOG(("WebSocketChannel::OnNetworkChangedTargetThread() - on target thread %p", this));
-
-- return mSocketThread->Dispatch(
-- NewRunnableMethod("net::WebSocketChannel::OnNetworkChanged",
-- this,
-- &WebSocketChannel::OnNetworkChanged),
-- NS_DISPATCH_NORMAL);
-+ if (!mDataStarted) {
-+ LOG(("WebSocket: data not started yet, no ping needed"));
-+ return NS_OK;
- }
-
-+ return mSocketThread->Dispatch(
-+ NewRunnableMethod("net::WebSocketChannel::OnNetworkChanged",
-+ this,
-+ &WebSocketChannel::OnNetworkChanged),
-+ NS_DISPATCH_NORMAL);
-+}
-+
-+nsresult
-+WebSocketChannel::OnNetworkChanged()
-+{
- MOZ_ASSERT(OnSocketThread(), "not on socket thread");
-
- LOG(("WebSocketChannel::OnNetworkChanged() - on socket thread %p", this));
diff --git a/www-client/seamonkey/files/seamonkey-2.53.7.1-rust-1.52.patch b/www-client/seamonkey/files/seamonkey-2.53.7.1-rust-1.52.patch
deleted file mode 100644
index 47c3995e41c5..000000000000
--- a/www-client/seamonkey/files/seamonkey-2.53.7.1-rust-1.52.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-http://www.wg9s.com/comm-253/patches/seamonkey-253-patches/mozilla-release/patches/1670538-87a1.patch
-https://bugs.gentoo.org/789981
-
---- seamonkey-2.53.7.1/config/rules.mk
-+++ seamonkey-2.53.7.1/config/rules.mk
-@@ -861,16 +861,27 @@
- # Versions of rust >= 1.45 need -Cembed-bitcode=yes for all crates when
- # using -Clto.
- ifeq (,$(filter 1.37.% 1.38.% 1.39.% 1.40.% 1.41.% 1.42.% 1.43.% 1.44.%,$(RUSTC_VERSION)))
- RUSTFLAGS += -Cembed-bitcode=yes
- endif
- endif
- endif
-
-+ifndef RUSTC_BOOTSTRAP
-+ifeq (,$(filter 1.47.% 1.48.% 1.49.%,$(RUSTC_VERSION)))
-+# RUSTC_BOOTSTRAP := gkrust_shared,qcms for later
-+RUSTC_BOOTSTRAP := gkrust_shared
-+ifdef MOZ_RUST_SIMD
-+RUSTC_BOOTSTRAP := $(RUSTC_BOOTSTRAP),encoding_rs,packed_simd
-+endif
-+export RUSTC_BOOTSTRAP
-+endif
-+endif
-+
- rustflags_override = RUSTFLAGS='$(MOZ_RUST_DEFAULT_FLAGS) $(RUSTFLAGS)'
-
- ifdef MOZ_MSVCBITS
- # If we are building a MozillaBuild shell, we want to clear out the
- # vcvars.bat environment variables for cargo builds. This is because
- # a 32-bit MozillaBuild shell on a 64-bit machine will try to use
- # the 32-bit compiler/linker for everything, while cargo/rustc wants
- # to use the 64-bit linker for build.rs scripts. This conflict results
---- seamonkey-2.53.7.1/toolkit/library/rust/shared/build.rs.1670538.later
-+++ seamonkey-2.53.7.1/toolkit/library/rust/shared/build.rs.1670538.later
-@@ -0,0 +1,16 @@
-+--- build.rs
-++++ build.rs
-+@@ -17,12 +17,12 @@ fn main() {
-+ } else if std::env::var("MOZ_AUTOMATION").is_ok() {
-+ panic!("Builds on automation must use a version of rust for which we know how to hook OOM: want < {}, have {}",
-+ max_oom_hook_version, ver);
-+ }
-+
-+ // This is a rather awful thing to do, but we're only doing it on
-+ // versions of rustc that are not going to change the unstable APIs
-+ // we use from under us, all being already released or beta.
-+- if bootstrap {
-++ if bootstrap && ver < Version::parse("1.50.0").unwrap() {
-+ println!("cargo:rustc-env=RUSTC_BOOTSTRAP=1");
-+ }
-+ }