summaryrefslogtreecommitdiff
path: root/www-client/ripe-atlas-cousteau/ripe-atlas-cousteau-1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/ripe-atlas-cousteau/ripe-atlas-cousteau-1.2.ebuild')
-rw-r--r--www-client/ripe-atlas-cousteau/ripe-atlas-cousteau-1.2.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/www-client/ripe-atlas-cousteau/ripe-atlas-cousteau-1.2.ebuild b/www-client/ripe-atlas-cousteau/ripe-atlas-cousteau-1.2.ebuild
deleted file mode 100644
index 5f8a43b24d84..000000000000
--- a/www-client/ripe-atlas-cousteau/ripe-atlas-cousteau-1.2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-MY_PN=${PN//-/.}
-DESCRIPTION="A Python wrapper around the RIPE Atlas API"
-HOMEPAGE="https://atlas.ripe.net/"
-SRC_URI="mirror://pypi/${PN:0:1}/ripe.atlas.cousteau/ripe.atlas.cousteau-${PV}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/${MY_PN}-${PVR}"
-
-DOCS=( CHANGES.rst README.rst )
-
-RDEPEND="
- >=dev-python/socketio-client-0.6.5[${PYTHON_USEDEP}]
- >=dev-python/requests-2.7.0[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}] )"
-
-python_test() {
- nosetests --verbose || die "Tests failed with ${EPYTHON}"
-}