summaryrefslogtreecommitdiff
path: root/www-client/ripe-atlas-cousteau/ripe-atlas-cousteau-1.0.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/ripe-atlas-cousteau/ripe-atlas-cousteau-1.0.7.ebuild')
-rw-r--r--www-client/ripe-atlas-cousteau/ripe-atlas-cousteau-1.0.7.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/www-client/ripe-atlas-cousteau/ripe-atlas-cousteau-1.0.7.ebuild b/www-client/ripe-atlas-cousteau/ripe-atlas-cousteau-1.0.7.ebuild
new file mode 100644
index 000000000000..80a11014143b
--- /dev/null
+++ b/www-client/ripe-atlas-cousteau/ripe-atlas-cousteau-1.0.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN=${PN//-/.}
+DESCRIPTION="A Python wrapper around the RIPE Atlas API"
+HOMEPAGE="https://atlas.ripe.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/ripe.atlas.cousteau/ripe.atlas.cousteau-${PVR}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+S="${WORKDIR}/${MY_PN}-${PVR}"
+
+RDEPEND="
+ >=dev-python/socketio-client-0.6.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.7.0[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ "${RDEPEND}"
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
+
+python_test() {
+ nosetests --verbose || die "Tests failed with ${EPYTHON}"
+}