summaryrefslogtreecommitdiff
path: root/www-client/firefox/firefox-68.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox/firefox-68.1.0.ebuild')
-rw-r--r--www-client/firefox/firefox-68.1.0.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/www-client/firefox/firefox-68.1.0.ebuild b/www-client/firefox/firefox-68.1.0.ebuild
index d2ca2f5da566..c11aaade6576 100644
--- a/www-client/firefox/firefox-68.1.0.ebuild
+++ b/www-client/firefox/firefox-68.1.0.ebuild
@@ -38,7 +38,7 @@ if [[ "${PV}" == *_rc* ]]; then
MOZ_SRC_URI="${MOZ_HTTP_URI}/source/${PN}-${MOZ_PV}.source.tar.xz -> $P.tar.xz"
fi
-LLVM_MAX_SLOT=8
+LLVM_MAX_SLOT=9
inherit check-reqs eapi7-ver flag-o-matic toolchain-funcs eutils \
gnome2-utils llvm mozcoreconf-v6 pax-utils xdg-utils \
@@ -47,7 +47,7 @@ inherit check-reqs eapi7-ver flag-o-matic toolchain-funcs eutils \
DESCRIPTION="Firefox Web Browser"
HOMEPAGE="https://www.mozilla.com/firefox"
-KEYWORDS="amd64 ~arm64 ~ppc64 x86"
+KEYWORDS="amd64 arm64 ~ppc64 x86"
SLOT="0"
LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
@@ -126,6 +126,15 @@ DEPEND="${CDEPEND}
sys-apps/findutils
|| (
(
+ sys-devel/clang:9
+ !clang? ( sys-devel/llvm:9 )
+ clang? (
+ =sys-devel/lld-9*
+ sys-devel/llvm:9[gold]
+ pgo? ( =sys-libs/compiler-rt-sanitizers-9*[profile] )
+ )
+ )
+ (
sys-devel/clang:8
!clang? ( sys-devel/llvm:8 )
clang? (