summaryrefslogtreecommitdiff
path: root/www-client/firefox/firefox-133.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox/firefox-133.0.3.ebuild')
-rw-r--r--www-client/firefox/firefox-133.0.3.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/www-client/firefox/firefox-133.0.3.ebuild b/www-client/firefox/firefox-133.0.3.ebuild
index 875c8205d782..d75faedfa125 100644
--- a/www-client/firefox/firefox-133.0.3.ebuild
+++ b/www-client/firefox/firefox-133.0.3.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-FIREFOX_PATCHSET="firefox-133-patches-03.tar.xz"
+FIREFOX_PATCHSET="firefox-133-patches-04.tar.xz"
LLVM_COMPAT=( 17 18 19 )
@@ -87,6 +87,7 @@ IUSE+=" +gmp-autoupdate gnome-shell +jumbo-build openh264 +telemetry wasm"
REQUIRED_USE="|| ( X wayland )
debug? ( !system-av1 )
+ pgo? ( jumbo-build )
wayland? ( dbus )
wifi? ( dbus )
"
@@ -978,6 +979,9 @@ src_configure() {
if use clang ; then
# Used in build/pgo/profileserver.py
export LLVM_PROFDATA="llvm-profdata"
+ else
+ export GCOV_PREFIX="${BUILD_DIR}"/instrumented
+ export GCOV_PREFIX_STRIP=$(( $(echo "${BUILD_DIR}"|tr -c -d '/' |wc -c )+2 ))
fi
fi