summaryrefslogtreecommitdiff
path: root/www-client/firefox/firefox-122.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox/firefox-122.0.ebuild')
-rw-r--r--www-client/firefox/firefox-122.0.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/www-client/firefox/firefox-122.0.ebuild b/www-client/firefox/firefox-122.0.ebuild
index ebd0851a2c90..0eb450b24d74 100644
--- a/www-client/firefox/firefox-122.0.ebuild
+++ b/www-client/firefox/firefox-122.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-FIREFOX_PATCHSET="firefox-122-patches-01.tar.xz"
+FIREFOX_PATCHSET="firefox-122-patches-02.tar.xz"
LLVM_MAX_SLOT=17
@@ -657,7 +657,7 @@ src_prepare() {
# Workaround for bgo#917599
if has_version ">=dev-libs/icu-74.1" && use system-icu ; then
- eapply "${WORKDIR}"/firefox-patches/0026-bmo-1862601-system-icu-74.patch
+ eapply "${WORKDIR}"/firefox-patches/*-bmo-1862601-system-icu-74.patch
fi
rm -v "${WORKDIR}"/firefox-patches/*-bmo-1862601-system-icu-74.patch || die
@@ -985,6 +985,8 @@ src_configure() {
if use clang ; then
# Upstream only supports lld or mold when using clang.
if tc-ld-is-mold ; then
+ # mold expects the -flto line from *FLAGS configuration, bgo#923119
+ append-ldflags "-flto=thin"
mozconfig_add_options_ac "using ld=mold due to system selection" --enable-linker=mold
else
mozconfig_add_options_ac "forcing ld=lld due to USE=clang and USE=lto" --enable-linker=lld