summaryrefslogtreecommitdiff
path: root/www-client/epiphany
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/epiphany')
-rw-r--r--www-client/epiphany/Manifest2
-rw-r--r--www-client/epiphany/epiphany-40.3.ebuild86
2 files changed, 88 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index 58c90c347dbf..708e3af371d2 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1,4 +1,6 @@
AUX var-tmp-tests.patch 659 BLAKE2B 2869f1c28c3a59974758986bd464aeb5c1d86d1b4e23f33d809529a1f1b800ffdb3daf24780774766a16c1f45fff145dd5524c682293dd117b29582adeade7ae SHA512 79480bed41ff59f423087dfd6d0f5eaee665fcba6602c7876ed63397edeb6cf5fcb2ce9f2f91b375117e389ec2fcf6cba1cf1e8919efef2ccad3c84547b7824a
DIST epiphany-40.2.tar.xz 5372180 BLAKE2B cd75f645980c37b0cdd92133505cf7961168bf5d67ad0bdf3140f155c737a070f7ffafa63bb8a0e5de175826b79b2ca380a2851e7f1f0454d4f372d48f48c9c7 SHA512 29a5b7e65f7e5decb3c370fc9ae654727cce30f397ffd3289a9f77f3527f0471c821e3bea0f1a5ab9c1ab44e670898b46e66e41de5cb8c76fabd23b135a4a1a9
+DIST epiphany-40.3.tar.xz 5379072 BLAKE2B d0b2ecd5db6953261efe6658fe60798b93b6589e1c79032f659a3d69dcf1e2ed77156bf46768c2891916a48f9a28474f8690e451c8631a0455f06d525f9349b5 SHA512 86d896142171f50d0375c4efec370986741d89f341b613c137fb4719ba5359a9e5523e52635c4bcc9ac7acf96f2276486d878d5ed44a57bc1c8124a01af2d30d
EBUILD epiphany-40.2.ebuild 1945 BLAKE2B 5fa7e097a85e8d4d0a1be45e48a98fa1c43d52a1c9e49dbbdf6de4712bf6442a3c9d8f8c50fce9f1573f276fa73c020bd66ce4d8546072249c28faace04fddc4 SHA512 6745e1cd14815143d0a35592df92d7c51c908f4d24e988e0b5b19cc495bc038996584969cb74a3d2d9fc375ed72d4ebce9115634482ce7eec4137d278462ee0c
+EBUILD epiphany-40.3.ebuild 1947 BLAKE2B 93fcbc0000d0bcd2e513a97ef6c590351844e5f4ad668c846c6756251767d74f227c5899bcd5f7c7e052ab21d4c37de2bdacffe434871104bdcebfd6c9928774 SHA512 202cde636523fc4d46ae05a10e525695ef82625880fa0dabdce4ccad96fb169abcdc584bf5994c10685a1d3fd301be9fa3259bd6d2cd5ca3efbee9323a1db52b
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/www-client/epiphany/epiphany-40.3.ebuild b/www-client/epiphany/epiphany-40.3.ebuild
new file mode 100644
index 000000000000..6e19aa0daada
--- /dev/null
+++ b/www-client/epiphany/epiphany-40.3.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson xdg virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.64.0:2
+ >=x11-libs/gtk+-3.24.0:3
+ >=dev-libs/nettle-3.4:=
+ >=net-libs/webkit-gtk-2.31.1:4=
+ >=x11-libs/cairo-1.2
+ >=app-crypt/gcr-3.5.5:=[gtk]
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ gnome-base/gsettings-desktop-schemas
+ >=app-text/iso-codes-0.35
+ >=dev-libs/json-glib-1.2.4
+ app-arch/libarchive:=
+ >=dev-libs/libdazzle-3.37.1
+ >=gui-libs/libhandy-1.1.0:1=
+ >=x11-libs/libnotify-0.5.1
+ >=app-crypt/libsecret-0.19
+ >=net-libs/libsoup-2.48.0:2.4
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-db/sqlite-3.22:3
+ dev-libs/gmp:0=
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+"
+# appstream-glib needed for appdata.xml gettext translation
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Allow /var/tmp prefixed recursive delete (due to package manager setting TMPDIR)
+ "${FILESDIR}"/var-tmp-tests.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Ddeveloper_mode=false
+ -Dlibportal=disabled
+ # maybe enable later if network-sandbox is off, but in 3.32.4 the network test
+ # is commented out upstream anyway
+ -Dnetwork_tests=disabled
+ -Dtech_preview=false
+ $(meson_feature test unit_tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version net-libs/webkit-gtk[jpeg2k]; then
+ ewarn "Your net-libs/webkit-gtk is built without USE=jpeg2k."
+ ewarn "Various image galleries/managers may be broken."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}