summaryrefslogtreecommitdiff
path: root/www-client/epiphany
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/epiphany')
-rw-r--r--www-client/epiphany/Manifest3
-rw-r--r--www-client/epiphany/epiphany-43.0.ebuild85
-rw-r--r--www-client/epiphany/files/43.0-Revert-tests-Set-locale-for-the-encodings-test.patch44
3 files changed, 132 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index f635a718b18b..33760a9c7128 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1,4 +1,7 @@
+AUX 43.0-Revert-tests-Set-locale-for-the-encodings-test.patch 1935 BLAKE2B 4b05f97f0e05b434f0684f18ccc07ac78b746e7eadc6a3e01a54de0c13a18771eb4976a00c9639027056988d8d17e27e6e8d5753a80dece391a8476c380c2c5d SHA512 b6ff49c29af43f84dcf5661df6218d2a7e078289c2c354cc9dd247f6e48aac1a932908f4d35beb6cc02eb0791ceafd7996cc6440b020b9c5d8d43051fdd31bd9
AUX var-tmp-tests.patch 659 BLAKE2B 2869f1c28c3a59974758986bd464aeb5c1d86d1b4e23f33d809529a1f1b800ffdb3daf24780774766a16c1f45fff145dd5524c682293dd117b29582adeade7ae SHA512 79480bed41ff59f423087dfd6d0f5eaee665fcba6602c7876ed63397edeb6cf5fcb2ce9f2f91b375117e389ec2fcf6cba1cf1e8919efef2ccad3c84547b7824a
DIST epiphany-42.4.tar.xz 6107820 BLAKE2B 7ab18ac6d8eceb3577ef53c761e26a64291219311f2d6d82ed13ce6746767b83124faf28c9627056938351a05e5d6aff50eb95eb4dec10ce8847123fb5775b36 SHA512 55153078bc460cc5a0bc17bb8d12fd5ed6495cd2415e128ec0b4917b07a4d2fe1fb74e871c033aaef43c89c125d79ad37e99ea2fa2ada07fbcdf09603129ae47
+DIST epiphany-43.0.tar.xz 3890284 BLAKE2B 74a463030bea6489dc05c975fa885ba3e06a3c552f18d29b0579121cf3b04f73fe3c76a6057d9d941f4361732ea1029cd7abb235969ca4f649964e5f909ea2d1 SHA512 56e65c2b3868447b88b89dc97c9d63c4ef1b174334eda15c6ad6b11a38963457df01a6024109ddfaf67730c691e5d68d37abb779604d4719dbc19950d18fe426
EBUILD epiphany-42.4-r1.ebuild 1982 BLAKE2B 5a6ffb9f5ca95ad91091c99683313ce4f8145037d008efb06282987a0c55fd9d1948ab72fd06d4bec774f932ff7cca5ea772a0732a67f18af40a4ee4e04d8c08 SHA512 8f0350fb915168f45fcc80846cc7e621cb827a8d86bde482831b8a5a97267cbf5e1991c5cf1a2feb37ad5ba7edb53c40ed7a93f583f4c84c9a64cf280167b15b
+EBUILD epiphany-43.0.ebuild 1942 BLAKE2B 0b5c0218f9eab71027f23b5554f5938f2a1bc742fdb5f20506164220c6c0a481bc8309d234e790a9fed8397c60f1f77aacdec8450ae72b6cea399ddea85f8b6a SHA512 5a81a596fada1455fe814b27b2e70e200718b184e966a97730844337e3a07b400dfefbdcc55cd3cc5a8f3cababf16bc3cbe032851d3658912e65d69b4a237f08
MISC metadata.xml 250 BLAKE2B 8f7f0fe023d43e380e7861e897e6afcb5de4baefb42ea9c65a57dfc0d204c6f787a99295141832e732ebb08be218da56ba77e2dd9639e4e3aabf718ce4db1d0c SHA512 2684e772dd6d83e4b49f08f2ba22d8a0a753e7b46863489eff1b5d1f2f147ad80ffd93245ca405ac4c747249bc1b754454ec9865fe16da70f9b257051e105fd8
diff --git a/www-client/epiphany/epiphany-43.0.ebuild b/www-client/epiphany/epiphany-43.0.ebuild
new file mode 100644
index 000000000000..407f55a1e1ee
--- /dev/null
+++ b/www-client/epiphany/epiphany-43.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web https://gitlab.gnome.org/GNOME/epiphany"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=x11-libs/cairo-1.2
+ >=app-crypt/gcr-3.5.5:0=[gtk]
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ >=dev-libs/glib-2.67.4:2
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/gtk+-3.24.0:3
+ >=app-text/iso-codes-0.35
+ >=dev-libs/json-glib-1.6
+ app-arch/libarchive:=
+ >=dev-libs/libdazzle-3.37.1
+ >=gui-libs/libhandy-1.5.0:1=
+ >=app-crypt/libsecret-0.19
+ >=net-libs/libsoup-2.99.4:3.0
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-libs/nettle-3.4:=
+ >=dev-libs/libportal-0.6:0=[gtk]
+ >=dev-db/sqlite-3.22:3
+ >=net-libs/webkit-gtk-2.37.1:4.1=
+
+ dev-libs/gmp:0=
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+"
+# appstream-glib needed for appdata.xml gettext translation
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-Revert-tests-Set-locale-for-the-encodings-test.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Ddeveloper_mode=false
+ # maybe enable later if network-sandbox is off, but in 3.32.4 the network test
+ # is commented out upstream anyway
+ -Dnetwork_tests=disabled
+ -Dtech_preview=false
+ $(meson_feature test unit_tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version net-libs/webkit-gtk:4.1[jpeg2k]; then
+ ewarn "Your net-libs/webkit-gtk:4.1 is built without USE=jpeg2k."
+ ewarn "Various image galleries/managers may be broken."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/www-client/epiphany/files/43.0-Revert-tests-Set-locale-for-the-encodings-test.patch b/www-client/epiphany/files/43.0-Revert-tests-Set-locale-for-the-encodings-test.patch
new file mode 100644
index 000000000000..973735712f36
--- /dev/null
+++ b/www-client/epiphany/files/43.0-Revert-tests-Set-locale-for-the-encodings-test.patch
@@ -0,0 +1,44 @@
+https://gitlab.gnome.org/GNOME/epiphany/-/issues/1842
+
+From 3fdab3173f64f8a8778ddc7f99167489f72c9eb0 Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Sun, 2 Oct 2022 23:24:40 -0400
+Subject: [PATCH] Revert "tests: Set locale for the encodings test"
+
+This reverts commit e54889f2aaae3f647dbdfdd7b40b8d43d19e7889.
+---
+ tests/ephy-encodings-test.c | 4 +---
+ 1 file changed, 1 insertion(+), 3 deletions(-)
+
+diff --git a/tests/ephy-encodings-test.c b/tests/ephy-encodings-test.c
+index a3ea7e781..a6bf38ab9 100644
+--- a/tests/ephy-encodings-test.c
++++ b/tests/ephy-encodings-test.c
+@@ -28,7 +28,6 @@
+ #include "ephy-shell.h"
+
+ #include <gtk/gtk.h>
+-#include <locale.h>
+
+ /* TODO: don't hardcode the number of encodings in ephy-encodings.c here! */
+ #define NUM_ENCODINGS 78
+@@ -44,7 +43,7 @@ test_ephy_encodings_create (void)
+ g_assert_cmpstr (ephy_encoding_get_encoding (encoding), ==, "UTF-8");
+ g_assert_cmpstr (ephy_encoding_get_title (encoding), ==, "Unicode (UTF-8)");
+ g_assert_cmpstr (ephy_encoding_get_title_elided (encoding), ==, "Unicode (UTF-8)");
+- g_assert_cmpstr (ephy_encoding_get_collation_key (encoding), ==, "\311\263\307\276\307\205\305\271\310\215\306\202\306\216\311\263\311\250\306\245\305\237\001\035\035\035\035\035\035\035\035\035\035\035\001\007\002\002\002\002\002\002\007\007\007\002\001\001\346\244\273\001\346\215\264\001\346\211\243\001\346\204\235\001\346\216\257\001\346\205\217\001\346\206\212\001\343\265\233\001\343\265\242\001\346\244\273\001\346\244\231\001\346\234\257\001\343\265\247\001\345\277\241\001\343\265\243");
++ g_assert_cmpstr (ephy_encoding_get_collation_key (encoding), ==, "Unicode (UTF-8)");
+ g_assert_cmpint (ephy_encoding_get_language_groups (encoding), ==, LG_UNICODE);
+
+ g_object_unref (encoding);
+@@ -80,7 +79,6 @@ main (int argc,
+ int ret;
+
+ gtk_test_init (&argc, &argv);
+- setlocale (LC_ALL, "");
+
+ ephy_debug_init ();
+
+--
+2.35.1
+