summaryrefslogtreecommitdiff
path: root/www-client/chromium/chromium-108.0.5359.124.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/chromium/chromium-108.0.5359.124.ebuild')
-rw-r--r--www-client/chromium/chromium-108.0.5359.124.ebuild23
1 files changed, 18 insertions, 5 deletions
diff --git a/www-client/chromium/chromium-108.0.5359.124.ebuild b/www-client/chromium/chromium-108.0.5359.124.ebuild
index 467c429a2729..ad27641369b5 100644
--- a/www-client/chromium/chromium-108.0.5359.124.ebuild
+++ b/www-client/chromium/chromium-108.0.5359.124.ebuild
@@ -12,16 +12,18 @@ CHROMIUM_LANGS="af am ar bg bn ca cs da de el en-GB es es-419 et fa fi fil fr gu
VIRTUALX_REQUIRED="pgo"
-inherit check-reqs chromium-2 desktop flag-o-matic llvm ninja-utils pax-utils python-any-r1 qmake-utils readme.gentoo-r1 toolchain-funcs virtualx xdg-utils
+inherit check-reqs chromium-2 desktop flag-o-matic llvm ninja-utils pax-utils
+inherit python-any-r1 qmake-utils readme.gentoo-r1 toolchain-funcs virtualx xdg-utils
DESCRIPTION="Open-source version of Google Chrome web browser"
HOMEPAGE="https://chromium.org/"
PATCHSET="2"
PATCHSET_NAME="chromium-$(ver_cut 1)-patchset-${PATCHSET}"
+PATCHSET_URI_PPC64="https://quickbuild.io/~raptor-engineering-public"
PATCHSET_NAME_PPC64="chromium_108.0.5359.71-2raptor0~deb11u1.debian"
SRC_URI="https://commondatastorage.googleapis.com/chromium-browser-official/${P}.tar.xz
https://github.com/stha09/chromium-patches/releases/download/${PATCHSET_NAME}/${PATCHSET_NAME}.tar.xz
- ppc64? ( https://quickbuild.io/~raptor-engineering-public/+archive/ubuntu/chromium/+files/${PATCHSET_NAME_PPC64}.tar.xz )
+ ppc64? ( ${PATCHSET_URI_PPC64}/+archive/ubuntu/chromium/+files/${PATCHSET_NAME_PPC64}.tar.xz )
pgo? ( https://github.com/elkablo/chromium-profiler/releases/download/v0.2/chromium-profiler-0.2.tar )"
LICENSE="BSD"
@@ -169,6 +171,9 @@ BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
')
>=app-arch/gzip-1.7
+ !headless? (
+ qt5? ( dev-qt/qtcore:5 )
+ )
libcxx? ( >=sys-devel/clang-13 )
lto? ( $(depend_clang_llvm_versions 13 14 15) )
pgo? (
@@ -606,6 +611,7 @@ src_prepare() {
third_party/dav1d
third_party/libaom
third_party/libaom/source/libaom/third_party/fastfeat
+ third_party/libaom/source/libaom/third_party/SVT-AV1
third_party/libaom/source/libaom/third_party/vector
third_party/libaom/source/libaom/third_party/x86inc
)
@@ -941,7 +947,16 @@ chromium_configure() {
myconf_gn+=" use_system_libdrm=true"
myconf_gn+=" use_system_minigbm=true"
myconf_gn+=" use_xkbcommon=true"
- use qt5 && export PATH="${PATH}:$(qt5_get_bindir)"
+ if use qt5; then
+ local moc_dir="$(qt5_get_bindir)"
+ if tc-is-cross-compiler; then
+ # Hack to workaround get_libdir not being able to handle CBUILD, bug #794181
+ local cbuild_libdir=$($(tc-getBUILD_PKG_CONFIG) --keep-system-libs --libs-only-L libxslt)
+ cbuild_libdir=${cbuild_libdir:2}
+ moc_dir="${EPREFIX}"/${cbuild_libdir/% }/qt5/bin
+ fi
+ export PATH="${PATH}:${moc_dir}"
+ fi
myconf_gn+=" use_qt=$(usex qt5 true false)"
myconf_gn+=" ozone_platform_x11=$(usex X true false)"
myconf_gn+=" ozone_platform_wayland=$(usex wayland true false)"
@@ -1012,8 +1027,6 @@ chromium_compile() {
# Don't inherit PYTHONPATH from environment, bug #789021, #812689
local -x PYTHONPATH=
- #"${EPYTHON}" tools/clang/scripts/update.py --force-local-build --gcc-toolchain /usr --skip-checkout --use-system-cmake --without-android || die
-
# Build mksnapshot and pax-mark it.
local x
for x in mksnapshot v8_context_snapshot_generator; do