summaryrefslogtreecommitdiff
path: root/www-apps
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/Manifest.gzbin13129 -> 13128 bytes
-rw-r--r--www-apps/nikola/Manifest1
-rw-r--r--www-apps/nikola/nikola-8.3.1-r1.ebuild67
-rw-r--r--www-apps/radicale/Manifest2
-rw-r--r--www-apps/radicale/radicale-3.5.0.ebuild96
5 files changed, 166 insertions, 0 deletions
diff --git a/www-apps/Manifest.gz b/www-apps/Manifest.gz
index 27b5f368b4b7..edade8c9fada 100644
--- a/www-apps/Manifest.gz
+++ b/www-apps/Manifest.gz
Binary files differ
diff --git a/www-apps/nikola/Manifest b/www-apps/nikola/Manifest
index c82ac543927c..139862345750 100644
--- a/www-apps/nikola/Manifest
+++ b/www-apps/nikola/Manifest
@@ -1,3 +1,4 @@
DIST Nikola-8.3.1.tar.gz 4559433 BLAKE2B 32bffeaf5f490f6c7bdf48b1c3b1906e4fb9a94fb196ecba8f0c2f074489b05e57c4278ae6ec8a6d91838772d19ddb0444166e05caa4d0d3055bd388b9b8cc63 SHA512 cbf4e099e2e1ee22ab16c8a3d3984617097721cb24cf03cf9673fc89d051fa712a05cbbfb522f85d6808155a0fa8835b1630096691a33c25aee8cf24564df050
+EBUILD nikola-8.3.1-r1.ebuild 2368 BLAKE2B 6322d893f5077e885e4051e91e53a90f62cef30428a705516424f0d33cd39af1697c3c5eabe06dd81f0a93ddb80c3efc47989ccc8b550045da639dd9111ada21 SHA512 54d84ef90b48a396e109253dff37389989eb77528c1f77036db49eedfcd83b7242ab48cd5db0e4190a998754475e2cb31fe9250eebbdb2a976946669a49e29e6
EBUILD nikola-8.3.1.ebuild 2364 BLAKE2B b018a8cf8260d263fbdaf0c69ccd93ce13ec9247fcd8af8ef5577f59e8b43f72fba8198fe9babb5b652fa10965850b7a8b3ca40a0fe230732be381bf589d28e8 SHA512 42c9d8f47676440ff07b46cf8b9d9a3f1cdd89df348474971cbee03cf85c57def4c5fca7c3ce95d171feb817dc8a77df8f21bf5b48cf5b97a6ac51a8dec2a9c9
MISC metadata.xml 292 BLAKE2B 0042bf60cec1af73f2d8e977e53c42adf5c7e4500f02ee08e3673b25962a86905d1d07783fb519a3bf40a12ab64229879e5fb217d1bde97195573fc6faa69f66 SHA512 a8e6a37da4e290629b38ccb4f9087682de58a0e4e4a377b85c3f3bb06eba426e3689cab575f528511fde9ed308e12a2e79a318e4dc55c6f85c3d8e16e22b3d01
diff --git a/www-apps/nikola/nikola-8.3.1-r1.ebuild b/www-apps/nikola/nikola-8.3.1-r1.ebuild
new file mode 100644
index 000000000000..d78629dd0c4c
--- /dev/null
+++ b/www-apps/nikola/nikola-8.3.1-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10,11,12,13} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit bash-completion-r1 distutils-r1 optfeature pypi
+
+DESCRIPTION="A static website and blog generator"
+HOMEPAGE="https://getnikola.com/"
+SRC_URI="$(pypi_sdist_url --no-normalize ${PN^} ${PV})"
+S="${WORKDIR}/${P^}"
+
+LICENSE="MIT Apache-2.0 CC0-1.0 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+RESTRICT="test" # needs coveralls
+
+BDEPEND=">=dev-python/docutils-0.13[${PYTHON_USEDEP}]" # needs rst2man to build manpage
+RDEPEND="${BDEPEND}
+ >=dev-python/babel-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/blinker-1.3[${PYTHON_USEDEP}]
+ >=dev-python/doit-0.32[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.3.5[${PYTHON_USEDEP}]
+ >=dev-python/mako-1.0[${PYTHON_USEDEP}]
+ >=dev-python/markdown-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/natsort-3.5.2[${PYTHON_USEDEP}]
+ >=dev-python/piexif-1.0.3[${PYTHON_USEDEP}]
+ >=dev-python/pygments-1.6[${PYTHON_USEDEP}]
+ >=dev-python/pyrss2gen-1.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-67.2.0[${PYTHON_USEDEP}]
+ >=dev-python/unidecode-0.04.16[${PYTHON_USEDEP}]
+ >=dev-python/yapsy-1.11.223[${PYTHON_USEDEP}]
+ dev-python/pillow[jpeg,${PYTHON_USEDEP}]
+ dev-python/cloudpickle[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ nikola tabcompletion --shell=bash > ${PN}.bashcomp || die
+ nikola tabcompletion --shell=zsh > ${PN}.zshcomp || die
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ # hackish way to remove docs that ended up in the wrong place
+ rm -r "${ED}/usr/share/doc/${PN}" || die
+
+ dodoc AUTHORS.txt CHANGES.txt README.rst docs/*.rst
+ gunzip "${ED}/usr/share/man/man1/${PN}.1.gz" || die
+
+ newbashcomp ${PN}.bashcomp ${PN}
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zshcomp _${PN}
+}
+
+pkg_postinst() {
+ optfeature "chart generation" dev-python/pygal
+ optfeature "hyphenation support" dev-python/pyphen
+ optfeature "notebook compilation and LESS support" dev-python/ipython
+ optfeature "alternative templating engine to Mako" dev-python/jinja2
+ optfeature "built-in web server support" dev-python/aiohttp
+ optfeature "monitoring file system events" dev-python/watchdog
+ optfeature "extracting metadata from web media links" dev-python/micawber
+}
diff --git a/www-apps/radicale/Manifest b/www-apps/radicale/Manifest
index 72ce4c32af18..073abe46410d 100644
--- a/www-apps/radicale/Manifest
+++ b/www-apps/radicale/Manifest
@@ -2,6 +2,8 @@ AUX radicale-r4.init.d 601 BLAKE2B 5b25d1b22fd3b531ceee7318d6389c0bb8e31bd2a6b26
AUX radicale.service 546 BLAKE2B 6d43e9b9aec713a944259e6323442f6796068ede3da5399f9081692b55fa0edc7ec72b35d190ec68f14972374c4da23178e84c7f4ff6df611c1f82e1e0b3029d SHA512 94705c36ddd4de14b608fa71cb8ee4fff3f4f12cf90cfeb3863c334e98ac5d19b34134d26c319d5d05b61efba8370addb87b8b6a6ad7005a17f8bfb35ff9013b
DIST Radicale-3.3.1.gh.tar.gz 170518 BLAKE2B 6c0230c94047a234fe1336cc62e4cb5e83639beb093ca02324c1a94f9580c36203089b1a915f9740a00cfa5f7708b7b3a3f252e2d8e7dd2aa85cacff636a4354 SHA512 d5fba7f433c6daedcc033170e33d4bc5ea9279ec6492dc1a966afe148441c4dba6cc762b7ad3181b70a0742b136eebcd4fec7d2438506d60a71d09395dcf20f1
DIST Radicale-3.4.1.gh.tar.gz 184481 BLAKE2B 87c200466bb7879305ef2b692e9483746fa82c475d85ba552164ab5092c4f08ca9f5b69d2449d1993bd8406ddaf37d9c259556744c37a6c1903a18fdd58c610e SHA512 6907fd696dac25eff85114673f182b6998872d02549147a894cd69654c44a0bec3a51adbf69dacde0c4cd9b7e3005dda8edc6c11f237df514ba3d06508684191
+DIST Radicale-3.5.0.gh.tar.gz 190792 BLAKE2B e0eeb1a9b0c5ce28481cdf3b840fec407a508cb5e38faab8c253cbcc15951f45b87ab4aff3b363fa88f112c2c44038b8fa1aae729145dbbb8837a4f6c65f2eb4 SHA512 00028bc94e4c41c844d24f51259ce8fb831194fd17e5fe29105d484d32c720295a45bb6ff44f9a1c4155b0143df5c0e74cef6eb8f9f48a0650c4cd89832f3620
EBUILD radicale-3.3.1.ebuild 2076 BLAKE2B c7c2d8da1964c51940b8182860849ebdb344a6322bbea6d580c6d3a7d999d327b3ff58be28bd9b197122cee21b875d82b7da40767ca92006c964ba1eb2caf86d SHA512 66bceee0d650a9b9653f01c9ea891fe07cf449973d1a0ad1181bd7c8a363ed215f102ff9f8892eb48a7e2c8c53b875123ec1820c1102d66afef7dd2ffd79b7ac
EBUILD radicale-3.4.1.ebuild 2133 BLAKE2B bed9ea676da5971c34f946cedc02a6ad5b898ced9f7d904b617134d93217015107427ee51c1a9392ac30b1da3579d46c45e0758557c389ed7a839a6d17e56e54 SHA512 9df3ef512e00e1e8a4abb08b3c954d3b74c5809a40db19b023cf35c1417b62fa52bc743483cb5bb20904b5bfbed1765feac2afb48f8dee701ad133cd0bb188d2
+EBUILD radicale-3.5.0.ebuild 2291 BLAKE2B a5068d5403054ad4c58bfecae31030db77632d9cba4dd557f91f4f9e72840e08ff1f6fcbb9152e57230558e45527db7ac54ca8c7eb6292e15fa03207c5a67745 SHA512 3367d357441571d43fe4736f8c9791d92ece0796def7e1536f90a2549ed7478c817a38b754689b637207d55d8fcbaceea265282b06d760c2379f109f146f4820
MISC metadata.xml 499 BLAKE2B e8aa182ad9b9388d6bbb527bff646b1e816343ddcbc95f8a9ee2eede2272f6470e1d543745c8ab9b907259c3b880332fb6d281e9771ea63696812956195bb277 SHA512 bb9b0a207af851714831c2aca9d020bcc728094c82ad15d519578e31499ff1999741279725ab6c306a25f0e4ccfd8399e39f2b42ca4eb821e677395aea8be842
diff --git a/www-apps/radicale/radicale-3.5.0.ebuild b/www-apps/radicale/radicale-3.5.0.ebuild
new file mode 100644
index 000000000000..9d14cefc3d3b
--- /dev/null
+++ b/www-apps/radicale/radicale-3.5.0.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature systemd
+
+MY_P=${P^}
+DESCRIPTION="A simple CalDAV calendar server"
+HOMEPAGE="https://radicale.org/"
+SRC_URI="
+ https://github.com/Kozea/Radicale/archive/refs/tags/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ >=acct-user/radicale-0-r2
+ acct-group/radicale
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/vobject[${PYTHON_USEDEP}]
+ sys-apps/util-linux
+"
+
+BDEPEND="
+ test? (
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/waitress[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+RDIR=/var/lib/"${PN}"
+
+DOCS=( DOCUMENTATION.md CHANGELOG.md )
+
+python_test() {
+ epytest -o addopts= radicale/tests/
+}
+
+python_install_all() {
+ rm README* || die
+ # init file
+ newinitd "${FILESDIR}"/radicale-r4.init.d radicale
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ # directories
+ keepdir "${RDIR}"
+ fperms 0750 "${RDIR}"
+ fowners "${PN}:${PN}" "${RDIR}"
+
+ # config file
+ insinto /etc/"${PN}"
+ doins config
+
+ # fcgi and wsgi files
+ exeinto /usr/share/"${PN}"
+ doexe radicale.wsgi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ local _erdir="${EROOT}${RDIR}"
+
+ ewarn ""
+ ewarn "Since 3.5.0 the default [auth] type is \"denyall\". You need to"
+ ewarn "change your config if you used the deafult type so far!"
+ ewarn ""
+ einfo "A sample WSGI script has been put into ${EROOT}/usr/share/${PN}."
+ einfo "You will also find there an example FastCGI script."
+ if [[ $(stat --format="%U:%G:%a" "${_erdir}") != "${PN}:${PN}:750" ]]
+ then
+ ewarn ""
+ ewarn "Unsafe file permissions detected on ${_erdir}."
+ ewarn "This probably comes from an earlier version of this ebuild."
+ ewarn "To fix run:"
+ ewarn "# \`chown -R ${PN}:${PN} ${_erdir}\`"
+ ewarn "# \`chmod 0750 ${_erdir}\`"
+ ewarn "# \`chmod -R o= ${_erdir}\`"
+ fi
+
+ optfeature "Publish changes to rabbitmq" dev-python/pika
+ optfeature "LDAP/LDAPS authentication" dev-python/ldap3 dev-python/python-ldap
+ optfeature "bcrypt password hashing" dev-python/bcrypt
+}