summaryrefslogtreecommitdiff
path: root/www-apps/roundup/roundup-2.0.0_beta0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/roundup/roundup-2.0.0_beta0.ebuild')
-rw-r--r--www-apps/roundup/roundup-2.0.0_beta0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/www-apps/roundup/roundup-2.0.0_beta0.ebuild b/www-apps/roundup/roundup-2.0.0_beta0.ebuild
new file mode 100644
index 000000000000..a3a4cebf17ba
--- /dev/null
+++ b/www-apps/roundup/roundup-2.0.0_beta0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..7} )
+
+inherit distutils-r1
+MY_P=${P/_/}
+
+DESCRIPTION="Issue-tracking system with command-line, web, and e-mail interfaces"
+HOMEPAGE="http://roundup.sourceforge.net https://pypi.org/project/roundup/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+tz sqlite mysql postgres xapian whoosh ssl jinja pyjwt markdown"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ tz? ( dev-python/pytz[$PYTHON_USEDEP] )
+ sqlite? ( dev-lang/python:*[sqlite] )
+ mysql? ( dev-python/mysqlclient[$PYTHON_USEDEP] )
+ postgres? ( >=dev-python/psycopg-2.8[$PYTHON_USEDEP] )
+ xapian? ( >=dev-libs/xapian-bindings-1.0.0[python,$PYTHON_USEDEP] )
+ whoosh? ( >=dev-python/whoosh-2.5.7[$PYTHON_USEDEP] )
+ ssl? ( dev-python/pyopenssl[$PYTHON_USEDEP] )
+ jinja? ( dev-python/jinja[$PYTHON_USEDEP] )
+ pyjwt? ( dev-python/pyjwt[$PYTHON_USEDEP] )
+ markdown? (
+ dev-python/markdown[$PYTHON_USEDEP]
+ dev-python/markdown2[$PYTHON_USEDEP]
+ dev-python/mistune[$PYTHON_USEDEP]
+ )"
+
+DOCS="CHANGES.txt doc/*.txt"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ rm -r "${ED}"/usr/share/doc/${PN} || die
+}
+
+pkg_postinst() {
+ ewarn "See installation.txt for initialisation instructions."
+ ewarn "See upgrading.txt for upgrading instructions."
+}