summaryrefslogtreecommitdiff
path: root/www-apps/postfixadmin
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/postfixadmin')
-rw-r--r--www-apps/postfixadmin/Manifest2
-rw-r--r--www-apps/postfixadmin/postfixadmin-3.3.10.ebuild105
2 files changed, 107 insertions, 0 deletions
diff --git a/www-apps/postfixadmin/Manifest b/www-apps/postfixadmin/Manifest
index cbb83d1ece6e..7d4dcf3d00be 100644
--- a/www-apps/postfixadmin/Manifest
+++ b/www-apps/postfixadmin/Manifest
@@ -1,4 +1,6 @@
AUX postinstall-en-2.3.txt 1827 BLAKE2B 49402566ddf6981cf0226f6a963fdd2c482957903583807f5c42731dfd5b4aea56de7d1ebd47ab6909f12492bd5e7a788322e0b2d80e15d883483a080f8fe11c SHA512 59e304d63830227b1619ed1299e9b61f5b6e534cb03da4d3a0e35a0fe727ccf2d994a034bd12d515bba4f8a6a8ca513cf2131c031fa63f85906639aca159993a
+DIST postfixadmin-3.3.10.tar.gz 1868307 BLAKE2B 489cac00205dbac9d1995f83a38a1817dfa207b2fd858ef87c0f4f3c45018759f6b2510e44da51f550df4182b0677cba346fd10a7fc3d4183672ebf70e64dd81 SHA512 b922ef08cbb3338e7581a78abb3077e92401019bea584710816615ab019a8cf678b22dbb068d0321550e2298f6a235b8a245c44c9f7eef02bb6b49b696225a2f
DIST postfixadmin-3.3.9.tar.gz 1866167 BLAKE2B 28546631dce340d3c1128b525de1c33e9e3aa23cd557e6c8f7e9b26f97aedba67f2e5f3ea351e0db2d79e068e16cfa1672cbe3e6abbffd19e5009e2a9df84523 SHA512 791b05df34a4f2eec01fe6f6b9038a6630cd60c42e1f2e725fe3d033a692b77d2d688858b947c53d1ce48258c7c87a2e3fb31356e553632b88149d5a29bfa70e
+EBUILD postfixadmin-3.3.10.ebuild 2903 BLAKE2B a69925b860f312a4ff94c7a8c2509ae4d8c149f37f99a6eebc7320ee14201e4409b11a64ecb32775a4ea57524365b5369b039d5bdb0572f7c926b9265d616afa SHA512 dcb90d76ee15cdbfb9ffa363c9dd840b5348378add396b21910ba9770704457c5b9670bec06902e0f9e79853e6a7149afa07fcfd800f80660d898c0301af561f
EBUILD postfixadmin-3.3.9-r2.ebuild 2901 BLAKE2B 19b5cb0f3397715224a29106f105bc5bf8c168e62880be57ed85693ff33b170c1ae6f32f1827b4392171f615509a00100067863b359499f951d461793032858a SHA512 4f7435f7b52b2f10ffd36e7abc3225921c39e4718ba4a8f4b163191a61ce8703e2a5d031168b2c19d80fa19d343aa11e24f592e39306e3a34f1688454dea1497
MISC metadata.xml 560 BLAKE2B 2dccae38d76ef72520678dcc26582c6d99d2221c8cad753063e4948b75cd84b39f47b854a010217a6a52186a7308a3355c41ab6a7229af2417deb39ccb3eae84 SHA512 4ab5d3db2584f100b9f1d9729eb50487e40b27d16c436cbe09dd03d24c533d5d7c61b4b19eda03aa423fb34d9cf2b9f3ec55679196bb8e8da5ea3157c0bc567b
diff --git a/www-apps/postfixadmin/postfixadmin-3.3.10.ebuild b/www-apps/postfixadmin/postfixadmin-3.3.10.ebuild
new file mode 100644
index 000000000000..7a74f56da1f4
--- /dev/null
+++ b/www-apps/postfixadmin/postfixadmin-3.3.10.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+DESCRIPTION="Web Based Management tool for Postfix style virtual domains and users"
+HOMEPAGE="http://postfixadmin.sourceforge.net"
+SRC_URI="https://github.com/postfixadmin/postfixadmin/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+mysql postgres +vacation"
+REQUIRED_USE="|| ( mysql postgres )"
+
+DEPEND="
+ dev-lang/php:*[unicode,imap,postgres?]
+ vacation? (
+ acct-group/vacation
+ acct-user/vacation
+ dev-perl/DBI
+ dev-perl/Email-Sender
+ dev-perl/Email-Valid
+ dev-perl/Log-Dispatch
+ dev-perl/Log-Log4perl
+ dev-perl/MIME-Charset
+ dev-perl/MIME-EncWords
+ mysql? ( dev-perl/DBD-mysql )
+ postgres? ( dev-perl/DBD-Pg )
+ )
+"
+
+RDEPEND="
+ ${DEPEND}
+ virtual/httpd-php
+ mysql? ( || ( dev-lang/php[mysqli] dev-lang/php[mysql] ) )
+"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ if use vacation; then
+ insinto /var/spool/vacation
+ newins VIRTUAL_VACATION/vacation.pl vacation.pl-${SLOT}
+ fowners vacation:vacation /var/spool/vacation/vacation.pl-${SLOT}
+ fperms 770 /var/spool/vacation/vacation.pl-${SLOT}
+ dodoc VIRTUAL_VACATION/FILTER_README
+ newdoc VIRTUAL_VACATION/INSTALL.md VIRTUAL_VACATION_INSTALL.md
+ rm -r VIRTUAL_VACATION/{vacation.pl,INSTALL.md,tests,FILTER_README} || die
+ fi
+
+ dodoc -r ADDITIONS
+
+ local docs="DOCUMENTS/*.txt INSTALL.TXT CHANGELOG.TXT"
+ dodoc ${docs}
+
+ rm -rf ${docs} DOCUMENTS/ GPL-LICENSE.TXT LICENSE.TXT debian/ tests/ ADDITIONS/
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config.inc.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-2.3.txt
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ einfo "Please note that if upgrading from version prior to 3.3.0,"
+ einfo "existing setup_password will no longer work and you will"
+ einfo "need to generate new one. See instructions in setup.php."
+
+ if use vacation; then
+ # portage does not update owners of directories (feature :)
+ chown vacation:vacation "${ROOT}"/var/spool/vacation/
+ einfo
+ einfo "/var/spool/vacation/vacation.pl symlink was updated to:"
+ einfo "/var/spool/vacation/vacation.pl-${SLOT}"
+ ln -sf "${ROOT}"/var/spool/vacation/vacation.pl{-${SLOT},} || die
+ fi
+}
+
+pkg_postrm() {
+ # Make sure we don't leave broken vacation.pl symlink
+ find -L "${ROOT}"/var/spool/vacation/ -type l -delete
+ local shopt_save=$(shopt -p nullglob)
+ shopt -s nullglob
+ local vacation=( "${ROOT}"/var/spool/vacation/vacation.pl-* )
+ ${shopt_save}
+ if [[ ! -e "${ROOT}"/var/spool/vacation/vacation.pl && -n ${vacation[@]} ]]; then
+ ln -s "${vacation[-1]}" "${ROOT}"/var/spool/vacation/vacation.pl || die
+ ewarn "/var/spool/vacation/vacation.pl was updated to point on most"
+ ewarn "recent verion, but please, do your own checks"
+ fi
+}