summaryrefslogtreecommitdiff
path: root/www-apache/mod_fastcgi_handler/mod_fastcgi_handler-0.6-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-apache/mod_fastcgi_handler/mod_fastcgi_handler-0.6-r2.ebuild')
-rw-r--r--www-apache/mod_fastcgi_handler/mod_fastcgi_handler-0.6-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/www-apache/mod_fastcgi_handler/mod_fastcgi_handler-0.6-r2.ebuild b/www-apache/mod_fastcgi_handler/mod_fastcgi_handler-0.6-r2.ebuild
new file mode 100644
index 000000000000..fb9676278d0d
--- /dev/null
+++ b/www-apache/mod_fastcgi_handler/mod_fastcgi_handler-0.6-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit apache-module
+
+DESCRIPTION="A simple FastCGI handler module"
+HOMEPAGE="https://github.com/hollow/mod_fastcgi_handler"
+SRC_URI="https://github.com/hollow/mod_fastcgi_handler/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+APACHE2_MOD_CONF="20_${PN}"
+APACHE2_MOD_DEFINE="FASTCGI_HANDLER"
+
+APXS2_ARGS="-o ${PN}.so -c *.c"
+
+need_apache2
+
+pkg_setup() {
+ # bug #653606
+ # but true cause seems to be bug #616612
+ _init_apache2
+ _init_apache2_late
+}