summaryrefslogtreecommitdiff
path: root/www-apache/mod_auth_xradius/mod_auth_xradius-0.4.6-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-apache/mod_auth_xradius/mod_auth_xradius-0.4.6-r2.ebuild')
-rw-r--r--www-apache/mod_auth_xradius/mod_auth_xradius-0.4.6-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/www-apache/mod_auth_xradius/mod_auth_xradius-0.4.6-r2.ebuild b/www-apache/mod_auth_xradius/mod_auth_xradius-0.4.6-r2.ebuild
new file mode 100644
index 000000000000..086e87e1dee0
--- /dev/null
+++ b/www-apache/mod_auth_xradius/mod_auth_xradius-0.4.6-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Radius authentication for Apache"
+HOMEPAGE="http://www.outoforder.cc/projects/apache/mod_auth_xradius/"
+SRC_URI="http://www.outoforder.cc/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="www-servers/apache"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-obsolete-autotools-syntax.patch
+ "${FILESDIR}"/${P}-fallback-support.patch
+ "${FILESDIR}"/${P}-apache24-api-changes.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
+src_prepare() {
+ default
+ AT_M4DIR="m4" eautoreconf
+}