summaryrefslogtreecommitdiff
path: root/sys-process/procps
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/procps')
-rw-r--r--sys-process/procps/Manifest3
-rw-r--r--sys-process/procps/files/procps-3.3.17-musl-fix.patch78
-rw-r--r--sys-process/procps/procps-3.3.17-r1.ebuild20
3 files changed, 99 insertions, 2 deletions
diff --git a/sys-process/procps/Manifest b/sys-process/procps/Manifest
index 7da274107a9f..b8cf91331d7c 100644
--- a/sys-process/procps/Manifest
+++ b/sys-process/procps/Manifest
@@ -1,5 +1,6 @@
AUX procps-3.3.11-sysctl-manpage.patch 941 BLAKE2B e10b6f85325d1ea23b327dffe4ba35662d5110492d0d5fcffad41edff21ddea4ea8c8bcb66582f63abd100a20d0d406e1c3fb176a8c290ba2cc6ecb02aa98248 SHA512 df8b233bde879fa675742baf8b38d43dd7c306fe52013ace715dff02c126d8c5ea12bd93087da10f5e722294eef59577b264309cbdc6f9f3727fa7111c5db313
AUX procps-3.3.12-proc-tests.patch 1835 BLAKE2B 99fe8d63620f37f98cddc60e8bcbaadbe5e7c54c4b0a65abad6ebe8a89f1b8f7f6bd29114b50678aa89cd0c89d26a95a10aa403d48bcc8371f16eaf34c823390 SHA512 ecc94717366a314ac4bba550b84472555f7b217be2174b68778d3364e16586ab9c21756d2041e2ac9d1449856fcd6aa691d8bd1a8558b4653d068dc1d59c2c71
+AUX procps-3.3.17-musl-fix.patch 1907 BLAKE2B 211d5512d9546592b23815bf4085447f6d07c0ac07cb03be01b520a56dc60fdfd07e9c055b0b40196efa2748f54eb5d8070cda80c5001d74fa5f261f53bd234c SHA512 5cf9852e54c307fedbf17b3a331ea992ea2c137120b6f89e4eeb7643091c09872e7e3bdcd2e80b83c46c02b2a0e0d56792afb7fe0564fa4f97e56f304b5792bd
DIST procps-ng-3.3.17.tar.xz 1008428 BLAKE2B 43aa1a21d4f0725b1c02457f343cf1fc66bc1771b25c6eaf689c9775c190e90545bfac1729f027abc4d3d13de37ffac4828554b5b25e12bcf6af9540de1695f3 SHA512 59e9a5013430fd9da508c4655d58375dc32e025bb502bb28fb9a92a48e4f2838b3355e92b4648f7384b2050064d17079bf4595d889822ebb5030006bc154a1a7
-EBUILD procps-3.3.17-r1.ebuild 2265 BLAKE2B cc8434921eac0274927fba6182113c980ac44e60760a11adf68dc6e9a598f20c4357568a2d08db10efda96964f307b6305929575e56167eec3c3c9c177e3e254 SHA512 1b39c4eb70e7e687b21e17933f446bc62b299c611e61b11691b1a9608277e5dcd87a97c5285015d1fe75122fdade7c378ddd7abfae3ca83c788155a9e4d103ba
+EBUILD procps-3.3.17-r1.ebuild 2895 BLAKE2B fe51fed783509ee3328e5f5cb990164a2a459cdf9a5e100c504e5a8ebc73af71af50ed323af45888c233826daa14620f4d4d750ddec100e1c5171a830212f3b1 SHA512 f3a7812a0209b2e2d4524056baaa122207349b867a2d07268e203fdd6c36cdd6d85fa88d54a85bebdd12c80f13779a0d076cef4bc139ab3b19832996ca153c8d
MISC metadata.xml 717 BLAKE2B caae5760de6bc3dbb19fef321255f8951a8ca70139511121dc6d497c8eac4a19ea1d08032e0b6538c74bb34242c8b394360e1fcbf65bd15ef3554e318fa2d4e3 SHA512 3a6a2fcf2dad8784e270bde8e6bc8b183e3dec14abe8c51a17316debac0b599a4f95dabd5e3e05344f500e8eb60b901062d17d644201bf4596e4580ba4d9494b
diff --git a/sys-process/procps/files/procps-3.3.17-musl-fix.patch b/sys-process/procps/files/procps-3.3.17-musl-fix.patch
new file mode 100644
index 000000000000..4402354c21e4
--- /dev/null
+++ b/sys-process/procps/files/procps-3.3.17-musl-fix.patch
@@ -0,0 +1,78 @@
+Temporary stopgap patch (a different solution was used upstream
+in the next release, should be in the next after 3.3.17 -- we'll need to
+add --disable-w instead).
+
+https://bugs.gentoo.org/794997
+
+From 7bfe2b7c12b33aabca71491360c433d2d3f7bbf4 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Wed, 24 Feb 2021 21:14:31 +0000
+Subject: [PATCH 1/2] w.c: correct musl builds
+
+No need to redefine UT_ stuff to something that does not exist.
+
+UT_ is already provided in musl but via utmp.h header, so include
+it always.
+
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ w.c | 9 +--------
+ 1 file changed, 1 insertion(+), 8 deletions(-)
+
+diff --git a/w.c b/w.c
+index 9d07ac9e..d10639b8 100644
+--- a/w.c
++++ b/w.c
+@@ -57,9 +57,8 @@
+ #include <unistd.h>
+ #ifdef HAVE_UTMPX_H
+ # include <utmpx.h>
+-#else
+-# include <utmp.h>
+ #endif
++#include <utmp.h>
+ #include <arpa/inet.h>
+
+ static int ignoreuser = 0; /* for '-u' */
+@@ -72,12 +71,6 @@ typedef struct utmpx utmp_t;
+ typedef struct utmp utmp_t;
+ #endif
+
+-#if !defined(UT_HOSTSIZE) || defined(__UT_HOSTSIZE)
+-# define UT_HOSTSIZE __UT_HOSTSIZE
+-# define UT_LINESIZE __UT_LINESIZE
+-# define UT_NAMESIZE __UT_NAMESIZE
+-#endif
+-
+ #ifdef W_SHOWFROM
+ # define FROM_STRING "on"
+ #else
+--
+GitLab
+
+
+From 145165aba6c659f3f0f3567a323a3e6170408ea6 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Wed, 24 Feb 2021 21:16:14 +0000
+Subject: [PATCH 2/2] proc/escape.c: add missing include
+
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ proc/escape.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/proc/escape.c b/proc/escape.c
+index 2e8fb7dd..e1f4612d 100644
+--- a/proc/escape.c
++++ b/proc/escape.c
+@@ -21,6 +21,7 @@
+ #include <sys/types.h>
+ #include <string.h>
+ #include <limits.h>
++#include <langinfo.h>
+ #include "procps.h"
+ #include "escape.h"
+ #include "readproc.h"
+--
+GitLab
+
diff --git a/sys-process/procps/procps-3.3.17-r1.ebuild b/sys-process/procps/procps-3.3.17-r1.ebuild
index 77bbf988516b..7045b992c869 100644
--- a/sys-process/procps/procps-3.3.17-r1.ebuild
+++ b/sys-process/procps/procps-3.3.17-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic multilib-minimal usr-ldscript
+inherit flag-o-matic multilib-minimal toolchain-funcs usr-ldscript
DESCRIPTION="Standard informational utilities and process-handling tools"
HOMEPAGE="http://procps-ng.sourceforge.net/ https://gitlab.com/procps-ng/procps"
@@ -42,7 +42,25 @@ PATCHES=(
"${FILESDIR}"/${PN}-3.3.12-proc-tests.patch # 583036
)
+src_prepare() {
+ default
+
+ # Please drop this after 3.3.17 and instead use --disable-w on musl.
+ # bug #794997
+ use elibc_musl && eapply "${FILESDIR}"/${PN}-3.3.17-musl-fix.patch
+}
+
multilib_src_configure() {
+ if tc-is-cross-compiler ; then
+ # This isn't ideal but upstream don't provide a placement
+ # when malloc is missing anyway, leading to errors like:
+ # pslog.c:(.text.startup+0x108): undefined reference to `rpl_malloc'
+ # See https://sourceforge.net/p/psmisc/bugs/71/
+ # (and https://lists.gnu.org/archive/html/autoconf/2011-04/msg00019.html)
+ export ac_cv_func_malloc_0_nonnull=yes \
+ ac_cv_func_realloc_0_nonnull=yes
+ fi
+
# http://www.freelists.org/post/procps/PATCH-enable-transparent-large-file-support
append-lfs-flags #471102
local myeconfargs=(