summaryrefslogtreecommitdiff
path: root/sys-process/procps/procps-4.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/procps/procps-4.0.4.ebuild')
-rw-r--r--sys-process/procps/procps-4.0.4.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/sys-process/procps/procps-4.0.4.ebuild b/sys-process/procps/procps-4.0.4.ebuild
index 2ddcefdad321..4e85c2be48ab 100644
--- a/sys-process/procps/procps-4.0.4.ebuild
+++ b/sys-process/procps/procps-4.0.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -17,7 +17,6 @@ LICENSE="GPL-2+ LGPL-2+ LGPL-2.1+"
SLOT="0/0-ng"
KEYWORDS="~alpha ~amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ~ppc64 ~riscv ~s390 sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="elogind +kill modern-top +ncurses nls selinux static-libs systemd test unicode"
-REQUIRED_USE="unicode? ( ncurses )"
RESTRICT="!test? ( test )"
DEPEND="
@@ -74,13 +73,17 @@ multilib_src_configure() {
$(multilib_native_use_with ncurses)
# bug #794997
$(multilib_native_use_enable !elibc_musl w)
- $(multilib_native_use_enable unicode watch8bit)
$(use_enable nls)
$(use_enable selinux libselinux)
$(use_enable static-libs static)
$(use_with systemd)
)
+ if use ncurses; then
+ # Only pass whis when we are building the 'watch' command
+ myeconfargs+=( $(multilib_native_use_enable unicode watch8bit) )
+ fi
+
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}