summaryrefslogtreecommitdiff
path: root/sys-process/numad/numad-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/numad/numad-9999.ebuild')
-rw-r--r--sys-process/numad/numad-9999.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/sys-process/numad/numad-9999.ebuild b/sys-process/numad/numad-9999.ebuild
index c44a0fea5cb3..d292669c500f 100644
--- a/sys-process/numad/numad-9999.ebuild
+++ b/sys-process/numad/numad-9999.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit linux-info toolchain-funcs eutils
+inherit linux-info toolchain-funcs
if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="git://git.fedorahosted.org/numad.git"
- inherit git-2
+ EGIT_REPO_URI="https://pagure.io/numad.git"
+ inherit git-r3
else
SRC_URI=""
KEYWORDS="~amd64 ~x86 -arm -s390"
@@ -23,14 +23,10 @@ IUSE=""
CONFIG_CHECK="~NUMA ~CPUSETS"
src_prepare() {
- epatch "${FILESDIR}"/0001-Fix-man-page-directory-creation.patch
+ default
tc-export CC
}
-src_configure() {
- :
-}
-
src_compile() {
emake CFLAGS="${CFLAGS} -std=gnu99"
}