summaryrefslogtreecommitdiff
path: root/sys-process/lsof/lsof-4.98.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/lsof/lsof-4.98.0-r1.ebuild')
-rw-r--r--sys-process/lsof/lsof-4.98.0-r1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/sys-process/lsof/lsof-4.98.0-r1.ebuild b/sys-process/lsof/lsof-4.98.0-r1.ebuild
index 77f81e741013..8505f4c5cb0f 100644
--- a/sys-process/lsof/lsof-4.98.0-r1.ebuild
+++ b/sys-process/lsof/lsof-4.98.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit flag-o-matic
+inherit autotools flag-o-matic
MY_P="${P/-/_}"
DESCRIPTION="Lists open files for running Unix processes"
@@ -30,8 +30,16 @@ RESTRICT="test"
PATCHES=(
"${FILESDIR}"/${P}-fix-common-include-strftime.patch
+ "${FILESDIR}"/${PN}-4.98.0-fix-clang-version-parser.patch
)
+# TODO: drop this block, "inherit autotools" and clang-version-parser patch after 4.99.3
+# https://github.com/lsof-org/lsof/pull/306
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
# TODO: drop after 4.98.0: https://github.com/lsof-org/lsof/commit/4fbe0b78f63ce115f25cf7a49756745e3bf47fea
export ac_cv_header_selinux_selinux_h=$(usex selinux)