summaryrefslogtreecommitdiff
path: root/sys-process/lsof/files/lsof-4.98.0-fix-clang-version-parser.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/lsof/files/lsof-4.98.0-fix-clang-version-parser.patch')
-rw-r--r--sys-process/lsof/files/lsof-4.98.0-fix-clang-version-parser.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/sys-process/lsof/files/lsof-4.98.0-fix-clang-version-parser.patch b/sys-process/lsof/files/lsof-4.98.0-fix-clang-version-parser.patch
new file mode 100644
index 000000000000..ebb5d85d2e5d
--- /dev/null
+++ b/sys-process/lsof/files/lsof-4.98.0-fix-clang-version-parser.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/919253
+https://github.com/lsof-org/lsof/issues/305
+
+Ignore HIP or CUDA versions in clang, when checking for compiler version
+--- a/configure.ac
++++ b/configure.ac
+@@ -410,7 +410,7 @@ AC_CONFIG_FILES([Makefile])
+
+ # Pass build configurations to version.h.in
+ AC_SUBST(cc, $CC)
+-AC_SUBST(ccv, $($CC -v 2>&1 | sed -n 's/.*version \(.*\)/\1/p'))
++AC_SUBST(ccv, $($CC -v 2>&1 | sed -n 's/.*version \(.*\)/\1/p;q'))
+ AC_SUBST(ccflags, $CFLAGS)
+ AC_SUBST(ldflags, "$LDFLAGS$LIBS")
+ # Reproducible build