summaryrefslogtreecommitdiff
path: root/sys-process/htop/htop-3.0.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/htop/htop-3.0.5-r1.ebuild')
-rw-r--r--sys-process/htop/htop-3.0.5-r1.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/sys-process/htop/htop-3.0.5-r1.ebuild b/sys-process/htop/htop-3.0.5-r1.ebuild
index 61702bf269c8..ef78ad9c82ac 100644
--- a/sys-process/htop/htop-3.0.5-r1.ebuild
+++ b/sys-process/htop/htop-3.0.5-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{7..9} )
-inherit autotools linux-info python-any-r1
+inherit autotools linux-info python-any-r1 xdg-utils
DESCRIPTION="interactive process viewer"
HOMEPAGE="https://htop.dev/ https://github.com/htop-dev/htop"
@@ -46,7 +46,7 @@ src_prepare() {
}
src_configure() {
- [[ $CBUILD != $CHOST ]] && export ac_cv_file__proc_{meminfo,stat}=yes #328971
+ [[ ${CBUILD} != ${CHOST} ]] && export ac_cv_file__proc_{meminfo,stat}=yes #328971
local myeconfargs=(
$(use_enable debug)
@@ -65,3 +65,13 @@ src_configure() {
econf ${myeconfargs[@]}
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}