summaryrefslogtreecommitdiff
path: root/sys-process/ctop/ctop-0.7.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/ctop/ctop-0.7.7.ebuild')
-rw-r--r--sys-process/ctop/ctop-0.7.7.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys-process/ctop/ctop-0.7.7.ebuild b/sys-process/ctop/ctop-0.7.7.ebuild
index bec6ba5b3f9f..6921a8a22a0f 100644
--- a/sys-process/ctop/ctop-0.7.7.ebuild
+++ b/sys-process/ctop/ctop-0.7.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -16,6 +16,8 @@ KEYWORDS="~amd64"
IUSE="hardened"
src_compile() {
+ sed -i -e '/go mod download/d' Makefile || die
+
export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"
emake VERSION="${PV}" BUILD="${PVR}" build
}