summaryrefslogtreecommitdiff
path: root/sys-process/cronbase/cronbase-0.3.7-r9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/cronbase/cronbase-0.3.7-r9.ebuild')
-rw-r--r--sys-process/cronbase/cronbase-0.3.7-r9.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-process/cronbase/cronbase-0.3.7-r9.ebuild b/sys-process/cronbase/cronbase-0.3.7-r9.ebuild
new file mode 100644
index 000000000000..e81da30e523f
--- /dev/null
+++ b/sys-process/cronbase/cronbase-0.3.7-r9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Base for all cron ebuilds"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+S="${WORKDIR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+DEPEND="acct-group/cron"
+RDEPEND="
+ ${DEPEND}
+ acct-user/cron
+"
+
+src_install() {
+ newsbin "${FILESDIR}"/run-crons-${PV} run-crons
+
+ diropts -m0750
+ keepdir /etc/cron.{hourly,daily,weekly,monthly}
+
+ keepdir /var/spool/cron/lastrun
+}