summaryrefslogtreecommitdiff
path: root/sys-power/throttled/throttled-0.10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/throttled/throttled-0.10.0.ebuild')
-rw-r--r--sys-power/throttled/throttled-0.10.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-power/throttled/throttled-0.10.0.ebuild b/sys-power/throttled/throttled-0.10.0.ebuild
new file mode 100644
index 000000000000..9b1a5e143ffa
--- /dev/null
+++ b/sys-power/throttled/throttled-0.10.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit linux-info python-single-r1 systemd
+
+DESCRIPTION="Daemon to work around throttling issues on some Intel laptops"
+HOMEPAGE="https://github.com/erpalma/throttled"
+SRC_URI="https://github.com/erpalma/throttled/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="test"
+
+CONFIG_CHECK="~X86_MSR ~DEVMEM"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ ')
+ sys-apps/pciutils
+"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ default
+ python_newscript throttled.py throttled
+ python_domodule mmio.py
+ newinitd "${FILESDIR}/throttled.initd" throttled
+ systemd_dounit "${FILESDIR}/throttled.service"
+ insinto /etc
+ doins etc/throttled.conf
+}