summaryrefslogtreecommitdiff
path: root/sys-power/thermald
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/thermald')
-rw-r--r--sys-power/thermald/Manifest2
-rw-r--r--sys-power/thermald/thermald-2.4.7.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-power/thermald/Manifest b/sys-power/thermald/Manifest
index 912942cdb25c..8e52314210b2 100644
--- a/sys-power/thermald/Manifest
+++ b/sys-power/thermald/Manifest
@@ -1,4 +1,6 @@
AUX thermald 374 BLAKE2B 2ea9775b75acb7797c078c8c7786d442bd9c98102cd53073e1c040a0972dfd6be8424a62889a666573ee72ce5273bc53169fae5762bc0005a1c899324a699d27 SHA512 17f1c2133e47e897c4a5407ef622adfebb8498fce7ea9bf17cfd177269a3d869bdc21c3d2558010e9669ddc53e69e521bb4c1e112c51010168aa3c074c259e02
DIST thermald-2.4.6.tar.gz 455905 BLAKE2B 0e3eae24bd4de8f7adc9cb8cc6dec83907d8e8240bec87d752e4502c923e7b407546204af474fe32fa43ba85a60ba51bd3dc6f1ce7cf3a62dd60dc5b0235ed52 SHA512 e337b00ec7f4fa565927f047dbb17dc05b8513850f2488dd6cfc838e5123938fbfe7c39464fffb77c100073edfca9ea51708680eaa2cba537470326df9508d3a
+DIST thermald-2.4.7.tar.gz 457290 BLAKE2B 2c546175181383c21d95345e4884e5d476a47b2c5f2e1dc379add5c340bd9f421567b7c391b6002e05e3ad793ba2f563d2eca7913f0688b53a8565f52da58fbf SHA512 26b09a18d40812705d277416752f7afd0962f0562d9701c9072140089b869c328f6b0caaa08744a660cd83b6a0313098a07aef11e1a2b371a81d2e8014c38887
EBUILD thermald-2.4.6.ebuild 1066 BLAKE2B cd1b730da42dc13c6163a04a2c81df89c1dcf708af8fc1632340692fb0d12048ce02d3a7b76e8cf7a94d1fb73abd48246ef36dc3e058766a3c36ce66a5b8207b SHA512 dd8ec95a533add81a462c1d71496ccfa86acbcd9ca2ef92b881daf9557f73508403397bb91117b33b4975008339ad09cb0fbc67a60bd10a91146d386062aae5b
+EBUILD thermald-2.4.7.ebuild 1068 BLAKE2B 53c9f13d82df3408d17c4c5588a4cea70f213ecc0b95ecf28b94accd8d69f1eced19c7de27d9dfad0e6a98738796b559c78b7bb78331a1477c1d9681068a0511 SHA512 a08160077fcfb0bdfeefae8eca90b3e552b38a6ef005a91398c2e87d7b9a503e8bb38c047ab55ef5110141c949789b09fd9eca8e648264b256f772027e91fae5
MISC metadata.xml 644 BLAKE2B 3ef4a9af01d461dcfcb83d7f17c024ee83eaa134e9b63ae00fe37d444ac626626af176581f010a397cb2fd91f00180c268e3e3b7371b454685b48b1ae76a2e93 SHA512 60e724e09ea9e7e21de4db80008b822070e8abd8cc72b9abf1ec4d486aa37fa9283f44bb7fd65a1d10d45e649073c4513cf0d4cad3ed25890b515f1053fbf4fa
diff --git a/sys-power/thermald/thermald-2.4.7.ebuild b/sys-power/thermald/thermald-2.4.7.ebuild
new file mode 100644
index 000000000000..f52005fc4eda
--- /dev/null
+++ b/sys-power/thermald/thermald-2.4.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools out-of-source systemd
+
+DESCRIPTION="Thermal daemon for Intel architectures"
+HOMEPAGE="https://01.org/linux-thermal-daemon https://github.com/intel/thermal_daemon"
+SRC_URI="https://github.com/intel/thermal_daemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/dbus-glib:=
+ dev-libs/glib:=
+ dev-libs/libxml2:=
+ dev-libs/libevdev
+ sys-power/upower
+ sys-apps/dbus:="
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+ dev-util/glib-utils"
+
+S=${WORKDIR}/thermal_daemon-${PV}
+DOCS=( thermal_daemon_usage.txt README.txt )
+
+src_prepare() {
+ sed -i -e "/group=/s/power/wheel/g" \
+ data/org.freedesktop.thermald.conf || die
+
+ default
+ eautoreconf
+}
+
+my_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-werror \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+}
+
+my_src_install_all() {
+ einstalldocs
+
+ rm -rf "${ED}"/etc/init || die
+ doinitd "${FILESDIR}"/thermald
+}