summaryrefslogtreecommitdiff
path: root/sys-power/powerstat/powerstat-0.02.21.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/powerstat/powerstat-0.02.21.ebuild')
-rw-r--r--sys-power/powerstat/powerstat-0.02.21.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/sys-power/powerstat/powerstat-0.02.21.ebuild b/sys-power/powerstat/powerstat-0.02.21.ebuild
new file mode 100644
index 000000000000..afaafaa50600
--- /dev/null
+++ b/sys-power/powerstat/powerstat-0.02.21.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Laptop power measuring tool"
+HOMEPAGE="https://launchpad.net/ubuntu/+source/powerstat https://github.com/ColinIanKing/powerstat"
+SRC_URI="https://github.com/ColinIanKing/${PN}/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Don't compress manpages
+PATCHES=( "${FILESDIR}"/"${PN}"-0.02.17-makefile.patch )
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}