summaryrefslogtreecommitdiff
path: root/sys-power/power-profiles-daemon/power-profiles-daemon-0.20.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/power-profiles-daemon/power-profiles-daemon-0.20.ebuild')
-rw-r--r--sys-power/power-profiles-daemon/power-profiles-daemon-0.20.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/sys-power/power-profiles-daemon/power-profiles-daemon-0.20.ebuild b/sys-power/power-profiles-daemon/power-profiles-daemon-0.20.ebuild
new file mode 100644
index 000000000000..f14d7178c710
--- /dev/null
+++ b/sys-power/power-profiles-daemon/power-profiles-daemon-0.20.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit meson python-single-r1 systemd
+
+DESCRIPTION="Makes power profiles handling available over D-Bus"
+HOMEPAGE="https://gitlab.freedesktop.org/upower/power-profiles-daemon/"
+SRC_URI="https://gitlab.freedesktop.org/upower/${PN}/-/archive/${PV}/${P}.tar.bz2"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+IUSE="gtk-doc selinux test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]')
+ dev-libs/glib:2
+ >=dev-libs/libgudev-234
+ >=sys-auth/polkit-0.99
+ sys-power/upower
+ selinux? ( sec-policy/selinux-powerprofiles )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ dev-util/gi-docgen
+ dev-util/gtk-doc
+ )
+ test? (
+ dev-util/umockdev
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-dbusmock[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ if use test; then
+ python_has_version "dev-python/python-dbusmock[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]"
+ else
+ python_has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]"
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dsystemdsystemunitdir="$(systemd_get_systemunitdir)"
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${D}"/usr/bin/powerprofilesctl
+ newinitd "${FILESDIR}/power-profiles-daemon.initd" power-profiles-daemon
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "You need to enable the service:"
+ if systemd_is_booted; then
+ elog "# systemctl enable ${PN}"
+ else
+ elog "# rc-update add ${PN} default"
+ fi
+ fi
+}