summaryrefslogtreecommitdiff
path: root/sys-power/apcupsd/apcupsd-3.14.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/apcupsd/apcupsd-3.14.13.ebuild')
-rw-r--r--sys-power/apcupsd/apcupsd-3.14.13.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sys-power/apcupsd/apcupsd-3.14.13.ebuild b/sys-power/apcupsd/apcupsd-3.14.13.ebuild
index b6e3eb60c4f7..b3489084c867 100644
--- a/sys-power/apcupsd/apcupsd-3.14.13.ebuild
+++ b/sys-power/apcupsd/apcupsd-3.14.13.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit eutils linux-info flag-o-matic systemd udev
+inherit eutils linux-info flag-o-matic systemd udev tmpfiles
DESCRIPTION="APC UPS daemon with integrated tcp/ip remote shutdown"
HOMEPAGE="http://www.apcupsd.org/"
@@ -93,7 +93,7 @@ src_install() {
newinitd "${FILESDIR}/${PN}.powerfail.init" "${PN}".powerfail
systemd_dounit "${FILESDIR}"/${PN}.service
- systemd_dotmpfilesd "${FILESDIR}"/${PN}-tmpfiles.conf
+ dotmpfiles "${FILESDIR}"/${PN}-tmpfiles.conf
# remove hal settings, we don't really want to have it around still.
rm -r "${D}"/usr/share/hal
@@ -106,6 +106,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process ${PN}-tmpfiles.conf
+
if use cgi; then
elog "The cgi-bin directory for ${PN} is /usr/libexec/${PN}/cgi-bin."
elog "Set up your ScriptAlias or symbolic links accordingly."