summaryrefslogtreecommitdiff
path: root/sys-power/acpi_call/acpi_call-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/acpi_call/acpi_call-9999.ebuild')
-rw-r--r--sys-power/acpi_call/acpi_call-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-power/acpi_call/acpi_call-9999.ebuild b/sys-power/acpi_call/acpi_call-9999.ebuild
new file mode 100644
index 000000000000..a2501dc4df20
--- /dev/null
+++ b/sys-power/acpi_call/acpi_call-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit linux-info linux-mod
+
+if [ "${PV}" = "9999" ]; then
+ inherit git-2
+ EGIT_REPO_URI="https://github.com/mkottman/acpi_call.git"
+ KEYWORDS=""
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/mkottman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A kernel module that enables you to call ACPI methods"
+HOMEPAGE="https://github.com/mkottman/acpi_call"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+CONFIG_CHECK="ACPI"
+MODULE_NAMES="acpi_call(misc:${S})"
+BUILD_TARGETS="default"
+
+src_compile(){
+ BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
+ linux-mod_src_compile
+}