summaryrefslogtreecommitdiff
path: root/sys-power/RyzenAdj/RyzenAdj-0.8.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/RyzenAdj/RyzenAdj-0.8.3.ebuild')
-rw-r--r--sys-power/RyzenAdj/RyzenAdj-0.8.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-power/RyzenAdj/RyzenAdj-0.8.3.ebuild b/sys-power/RyzenAdj/RyzenAdj-0.8.3.ebuild
new file mode 100644
index 000000000000..dff6f45cdbed
--- /dev/null
+++ b/sys-power/RyzenAdj/RyzenAdj-0.8.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="The power management tool for mobile and desktop Ryzen APUs"
+HOMEPAGE="https://github.com/FlyGoat/RyzenAdj"
+SRC_URI="https://github.com/FlyGoat/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-apps/pciutils"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_configure() {
+ CMAKE_BUILD_TYPE="Release"
+ cmake_src_configure
+}
+
+src_install() {
+ dosbin "${BUILD_DIR}"/ryzenadj
+
+ dolib.so "${BUILD_DIR}"/libryzenadj.so
+
+ dodoc "${S}"/README.md
+}