summaryrefslogtreecommitdiff
path: root/sys-libs/timezone-data
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/timezone-data')
-rw-r--r--sys-libs/timezone-data/Manifest2
-rw-r--r--sys-libs/timezone-data/timezone-data-2025a-r1.ebuild (renamed from sys-libs/timezone-data/timezone-data-2025a.ebuild)43
2 files changed, 13 insertions, 32 deletions
diff --git a/sys-libs/timezone-data/Manifest b/sys-libs/timezone-data/Manifest
index 686a0f6a2208..9aab088806ce 100644
--- a/sys-libs/timezone-data/Manifest
+++ b/sys-libs/timezone-data/Manifest
@@ -6,5 +6,5 @@ DIST tzdb-2024b.tar.lz 544381 BLAKE2B 7e9e7d88aa25813c461bd9a9653fcb5e9b212bd07f
DIST tzdb-2025a.tar.lz 548434 BLAKE2B cccd37ca71bfde7e56ed5138be5a610ec9d5ca59658b90e5e2a10af9221ed6d09b24b106bef46b04bbc97bff74b6e97a1f800c078a523aa32c13416a33264df2 SHA512 1e8c4e141158d63ca5c39babc9d18c32df14e2e59bc7649a7fed8c3e577f7b175bafa43883cf351139ff198515f5f8c22b1418e2ac7efb7f837faa8f61d2574d
EBUILD timezone-data-2024a-r1.ebuild 5321 BLAKE2B d2e649172a2193fdc5844727a156683b9bc28c3386c754c949f0e3a3edef9a8a26a710f75697b1bb635b5e7be79c31e1abb81e1bb21abfb18756d7657fd336e3 SHA512 6c2b9de0467ac8a5285faf7b85b71bc2b632c72c397b2caa6467417a3c80ee6866c60991e5db73312e8d42ffd7108ddcf42d8ae1eab151131b7792a82416d4bb
EBUILD timezone-data-2024b.ebuild 5043 BLAKE2B 7d8f15ae7bcca725bc8d90625b8d92aca27a99c17e642bd0d34753b17217343dd9525501d0e0c14d0a1c15018ecbe7f8b451baf21d4c5c8dbbfda2f6c9a2959e SHA512 b1215e4004224fb3c3237fcad753f8bb549943065f8c539de9579e71aadfbb7c656d76827143bb7c67732fe9c25fddb24af62073993b10a0cf8d88374095a912
-EBUILD timezone-data-2025a.ebuild 4986 BLAKE2B cc5bad00c4845e5edbfe40371b1d396016f72f8d05b8b7473c415a25ee78ada72185e1bb52013b648339f809df5455765db4b120864e632ac2644bfedefee819 SHA512 1bba21a27b9cfd4ea8efe1236d377ae99cba5732339161262759a00bc9f3df8bb43064d6c7fed7b16b5f70718d30bacffc4897b9600608022dd6fb6fc8d4e977
+EBUILD timezone-data-2025a-r1.ebuild 4187 BLAKE2B 9fa41aad5030a4c1eec4fe49d249a40897524f739e6b9de50c8050097a82535e130478df30559f1edd0a2910254be945a6d91a289793b9a220a6ff95558d6a39 SHA512 bf571c12ff22f4c3ebc47a4c77cad5eb21856dc01da683684fb74b3686a13e7dd6d0f6ff2818866df363d7bbd0bb40bec1c98b94fe156ba6bd20df2853f489af
MISC metadata.xml 807 BLAKE2B 24b09c4228c232b607e6e6c165a20e364136d77aa970e72c70124636a038cd3b672bad16ddd68c0b75373be6a09f969e59bc38f7e451bb2869cd46c521e2ca82 SHA512 0b95b32d79651493a04032f175f3320d8975cea714b43fa56aa528f10f51a7c52b58a934828f98a770855485af6f8db048bd2bfa3010802cff8c26ae05bb16e2
diff --git a/sys-libs/timezone-data/timezone-data-2025a.ebuild b/sys-libs/timezone-data/timezone-data-2025a-r1.ebuild
index 5f698fb9c37b..30f819547544 100644
--- a/sys-libs/timezone-data/timezone-data-2025a.ebuild
+++ b/sys-libs/timezone-data/timezone-data-2025a-r1.ebuild
@@ -107,31 +107,6 @@ src_install() {
dodoc CONTRIBUTING README NEWS *.html
}
-get_TIMEZONE() {
- local tz src="${EROOT}/etc/timezone"
- if [[ -e ${src} ]] ; then
- tz=$(sed -e 's:#.*::' -e 's:[[:space:]]*::g' -e '/^$/d' "${src}")
- else
- tz="FOOKABLOIE"
- fi
-
- [[ -z ${tz} ]] && return 1 || echo "${tz}"
-}
-
-pkg_preinst() {
- local tz=$(get_TIMEZONE)
- if [[ ${tz} == right/* || ${tz} == posix/* ]] ; then
- eerror "The right & posix subdirs are no longer installed as subdirs -- they have been"
- eerror "relocated to match upstream paths as sibling paths. Further, posix/xxx is the"
- eerror "same as xxx, so you should simply drop the posix/ prefix. You also should not"
- eerror "be using right/xxx for the system timezone as it breaks programs."
- die "Please fix your timezone setting"
- fi
-
- # Trim the symlink by hand to avoid portage's automatic protection checks.
- rm -f "${EROOT}"/usr/share/zoneinfo/posix
-}
-
configure_tz_data() {
# Make sure the /etc/localtime file does not get stale, bug #127899
local tz src="${EROOT}/etc/timezone" etc_lt="${EROOT}/etc/localtime"
@@ -139,17 +114,23 @@ configure_tz_data() {
# If it's a symlink, assume the user knows what they're doing and
# they're managing it themselves, bug #511474
if [[ -L "${etc_lt}" ]] ; then
- einfo "Assuming your ${etc_lt} symlink is what you want; skipping update."
+ einfo "Skipping update: ${etc_lt} is a symlink."
+ if [[ -e ${src} ]]; then
+ einfo "Removing ${src}."
+ rm "${src}"
+ fi
return 0
fi
- if ! tz=$(get_TIMEZONE) ; then
- einfo "Assuming your empty ${src} file is what you want; skipping update."
+ if [[ ! -e ${src} ]] ; then
+ einfo "Skipping update: ${src} does not exist."
return 0
fi
- if [[ "${tz}" == "FOOKABLOIE" ]] ; then
- einfo "You do not have a timezone set in ${src}; skipping update."
+ tz=$(sed -e 's:#.*::' -e 's:[[:space:]]*::g' -e '/^$/d' "${src}")
+
+ if [[ -z ${tz} ]]; then
+ einfo "Skipping update: ${src} is empty."
return 0
fi
@@ -164,7 +145,7 @@ configure_tz_data() {
# If a regular file already exists, copy over it.
ewarn "Found a regular file at ${etc_lt}."
ewarn "Some software may expect a symlink instead."
- ewarn "You may convert it to a symlink by removing the file and running:"
+ ewarn "Convert it to a symlink by removing the file and running:"
ewarn " emerge --config sys-libs/timezone-data"
einfo "Copying ${tzpath} to ${etc_lt}."
cp -f "${tzpath}" "${etc_lt}"