summaryrefslogtreecommitdiff
path: root/sys-libs/pam/files
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/pam/files')
-rw-r--r--sys-libs/pam/files/pam-1.5.1-musl.patch15
-rw-r--r--sys-libs/pam/files/pam-1.5.2-clang-15-configure-implicit-func.patch29
2 files changed, 0 insertions, 44 deletions
diff --git a/sys-libs/pam/files/pam-1.5.1-musl.patch b/sys-libs/pam/files/pam-1.5.1-musl.patch
deleted file mode 100644
index a1d5b1543daf..000000000000
--- a/sys-libs/pam/files/pam-1.5.1-musl.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Fix undefined reference to `libintl_dgettext` on musl
-Bug: https://bugs.gentoo.org/832573
-Upstream: https://github.com/linux-pam/linux-pam/pull/433
-
---- a/libpam/Makefile.am
-+++ b/libpam/Makefile.am
-@@ -21,7 +21,7 @@ noinst_HEADERS = pam_prelude.h pam_private.h pam_tokens.h \
- include/pam_inline.h include/test_assert.h
-
- libpam_la_LDFLAGS = -no-undefined -version-info 85:1:85
--libpam_la_LIBADD = @LIBAUDIT@ $(LIBPRELUDE_LIBS) $(ECONF_LIBS) @LIBDL@
-+libpam_la_LIBADD = @LIBAUDIT@ $(LIBPRELUDE_LIBS) $(ECONF_LIBS) @LIBDL@ @LTLIBINTL@
-
- if HAVE_VERSIONING
- libpam_la_LDFLAGS += -Wl,--version-script=$(srcdir)/libpam.map
diff --git a/sys-libs/pam/files/pam-1.5.2-clang-15-configure-implicit-func.patch b/sys-libs/pam/files/pam-1.5.2-clang-15-configure-implicit-func.patch
deleted file mode 100644
index 5ad7b8c4776e..000000000000
--- a/sys-libs/pam/files/pam-1.5.2-clang-15-configure-implicit-func.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-https://github.com/linux-pam/linux-pam/pull/490
-
-From 5fccc4cbac82b4677af28b59e7a657c86acab7fc Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Sun, 11 Sep 2022 16:37:59 +0100
-Subject: [PATCH] configure.ac: fix implicit function declaration in mail spool
- directory check
-
-Fixes the following error with Clang 15 (which makes implicit function
-declarations an error by default):
-```
-+error: call to undeclared library function 'exit' with type 'void (int) __attribute__((noreturn))'; ISO C99 and later do not support implicit function declarations [-Wimplicit-function-declaration]
- exit(0);
- ^
- note: include the header <stdlib.h> or explicitly provide a declaration for 'exit'
-```
-
-Signed-off-by: Sam James <sam@gentoo.org>
---- a/configure.ac
-+++ b/configure.ac
-@@ -297,6 +297,7 @@ if test x$with_mailspool != x ; then
- else
- AC_RUN_IFELSE([AC_LANG_SOURCE([[
- #include <paths.h>
-+#include <stdlib.h>
- int main() {
- #ifdef _PATH_MAILDIR
- exit(0);
-