summaryrefslogtreecommitdiff
path: root/sys-libs/newlib/newlib-2.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/newlib/newlib-2.0.0.ebuild')
-rw-r--r--sys-libs/newlib/newlib-2.0.0.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/sys-libs/newlib/newlib-2.0.0.ebuild b/sys-libs/newlib/newlib-2.0.0.ebuild
deleted file mode 100644
index 480700b42b49..000000000000
--- a/sys-libs/newlib/newlib-2.0.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-inherit flag-o-matic toolchain-funcs
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY} == cross-* ]] ; then
- export CTARGET=${CATEGORY#cross-}
- fi
-fi
-
-DESCRIPTION="Newlib is a C library intended for use on embedded systems"
-HOMEPAGE="https://sourceware.org/newlib/"
-SRC_URI="ftp://sourceware.org/pub/newlib/${P}.tar.gz"
-
-LICENSE="NEWLIB LIBGLOSS GPL-2"
-SLOT="0"
-KEYWORDS="-* arm hppa m68k ~mips ppc ppc64 sh sparc x86"
-IUSE="nls threads unicode headers-only"
-RESTRICT="strip"
-
-NEWLIBBUILD="${WORKDIR}/build"
-
-pkg_setup() {
- # Reject newlib-on-glibc type installs
- if [[ ${CTARGET} == ${CHOST} ]] ; then
- case ${CHOST} in
- *-newlib|*-elf) ;;
- *) die "Use sys-devel/crossdev to build a newlib toolchain" ;;
- esac
- fi
-}
-
-src_configure() {
- # we should fix this ...
- unset LDFLAGS
- CHOST=${CTARGET} strip-unsupported-flags
-
- local myconf=""
- [[ ${CTARGET} == "spu" ]] \
- && myconf="${myconf} --disable-newlib-multithread" \
- || myconf="${myconf} $(use_enable threads newlib-multithread)"
-
- mkdir -p "${NEWLIBBUILD}"
- cd "${NEWLIBBUILD}"
-
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable unicode newlib-mb) \
- $(use_enable nls) \
- ${myconf}
-}
-
-src_compile() {
- emake -C "${NEWLIBBUILD}"
-}
-
-src_install() {
- cd "${NEWLIBBUILD}"
- emake -j1 DESTDIR="${D}" install
- # minor hack to keep things clean
- rm -fR "${D}"/usr/share/info
- rm -fR "${D}"/usr/info
-}