summaryrefslogtreecommitdiff
path: root/sys-libs/llvm-libunwind/llvm-libunwind-13.0.0.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/llvm-libunwind/llvm-libunwind-13.0.0.9999.ebuild')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-13.0.0.9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-13.0.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-13.0.0.9999.ebuild
index a4b1aceef510..5d782b4128b2 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-13.0.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-13.0.0.9999.ebuild
@@ -44,7 +44,7 @@ multilib_src_configure() {
# link to compiler-rt
# https://github.com/gentoo/gentoo/pull/21516
if tc-is-clang; then
- local compiler-rt=$($(tc-getCC) ${CFLAGS} ${CPPFLAGS} \
+ local compiler_rt=$($(tc-getCC) ${CFLAGS} ${CPPFLAGS} \
${LD_FLAGS} -print-libgcc-file-name)
if [[ ${compiler_rt} == *libclang_rt* ]]; then
use_compiler_rt=ON
@@ -82,7 +82,7 @@ wrap_libcxxabi() {
local mycmakeargs=(
-DLIBCXXABI_LIBDIR_SUFFIX=
-DLIBCXXABI_ENABLE_SHARED=OFF
- -DLIBCXXABI_ENABLE_STATIC=ONF
+ -DLIBCXXABI_ENABLE_STATIC=ON
-DLIBCXXABI_USE_LLVM_UNWINDER=ON
-DLIBCXXABI_INCLUDE_TESTS=OFF