summaryrefslogtreecommitdiff
path: root/sys-libs/libvpd
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libvpd')
-rw-r--r--sys-libs/libvpd/Manifest4
-rw-r--r--sys-libs/libvpd/files/2.2.8-gcc11.patch84
-rw-r--r--sys-libs/libvpd/files/2.2.8-warnings.patch52
-rw-r--r--sys-libs/libvpd/libvpd-2.2.8-r1.ebuild (renamed from sys-libs/libvpd/libvpd-2.2.8.ebuild)7
4 files changed, 145 insertions, 2 deletions
diff --git a/sys-libs/libvpd/Manifest b/sys-libs/libvpd/Manifest
index 38a0fa01ba17..ac9d0e127109 100644
--- a/sys-libs/libvpd/Manifest
+++ b/sys-libs/libvpd/Manifest
@@ -1,3 +1,5 @@
+AUX 2.2.8-gcc11.patch 3279 BLAKE2B 50816aa628d6c9b3f9c9d27b1a4550a10c83fafc9a95dd5a9f499a68534fa96b4ce6fd73d7b28777e09dfe45580b7928a7370e51f1784f59c6ee7e78dd45d2a2 SHA512 817d00ffb794b685f5c20625dba50950ea67baae8cd7d4120e907d789bd93d5ea306681dd384296782d6037560b72aefd5db9c004a8a711a4e3df0aa639746e2
+AUX 2.2.8-warnings.patch 2326 BLAKE2B 71a480bedc290a447ae988ed96d4ec3b8f68fc74773c39c0b813b0083c69f5bb659fbbee078b741c496c46f1906e6e6c47bf5acbb29c2b8064b8eefa79851828 SHA512 b095be3e4d9cfe03d8b01d0d1861df2934a7695cc1585af556702dee9c6692fbbe68ea1266181250f72ff74d97694516329de0fde00cd574d60eff004d7083e1
DIST libvpd-2.2.8.tar.gz 52725 BLAKE2B 76bdc6ddf80236a6848185273c2cac181d44214f0c609d7c5af6fa4d09a7cd816324af35745617ce3daa7268311e2ed754335600df1d4970a324eb327015d051 SHA512 d0b7d1760c6ae54717c538405c651317b7318dec5780961f5386c09b7d245e35a84c2fc47d89c47c3cd2168d73d7186f5819981d52c3ba962514639833dc62aa
-EBUILD libvpd-2.2.8.ebuild 909 BLAKE2B 6b3e715ce6d8c736d205340513b93479f1c8d176e29b2e162f27d448f8d08fe962232050a44eb57c46d9049c4a4cf5af8f533a4061dd2670b6504e579042abd4 SHA512 c1af2a36595cae47c3d803b2ce14e664587aa7348376f03f194d5d89a7c64e86c15e8da0aff50858a8862bf194b8dfaa597b3000fa4940dce91d38ac4c304e08
+EBUILD libvpd-2.2.8-r1.ebuild 991 BLAKE2B 8e3145531b1e1dbae7eeba2e0df7c7810d6045f93c97c83567bdd786c33b2913662f54be950e9677e2ff6b34dd8a904a738ad2ed4863e1497de5418a6114e4e3 SHA512 716bb2e1d385ec53f99281f7f1bc8c466c266461570f65b8e700263bf8ab9a484c3efeb1ec81f0816efd77a765038f7e41a23df533f1ced7dcd5571853564003
MISC metadata.xml 343 BLAKE2B 88ff852b7b901d0f81c494ab49f283835edb7e312965526050fde66fcf0b259c197e0b1b312e09910a77257e4e1b8d8f3fd6c465b95a9fbe7288b8d64a4a6659 SHA512 42f1b8b76a107cfa61ae9db8b900aed22a3bc8e8d3573dbb3c507ebde688ef2c50f7f79847eb345e738365fbb99ba22d99aee56e302c6eed064379ddc1e3a710
diff --git a/sys-libs/libvpd/files/2.2.8-gcc11.patch b/sys-libs/libvpd/files/2.2.8-gcc11.patch
new file mode 100644
index 000000000000..7e09f8329bba
--- /dev/null
+++ b/sys-libs/libvpd/files/2.2.8-gcc11.patch
@@ -0,0 +1,84 @@
+From 83ccb994e30364c0703d7b8c15817d56b42da2e6 Mon Sep 17 00:00:00 2001
+From: Kamalesh Babulal <kamalesh@linux.vnet.ibm.com>
+Date: Wed, 7 Apr 2021 14:11:41 +0530
+Subject: [PATCH] Remove dynamic exception specification
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Tomasz Kłoczko reported that the build fails, while compiling
+with GCC 11:
+
+In file included from src/vpdretriever.cpp:25:
+./src/libvpd-2/vpdretriever.hpp:62:33: error: ISO C++17 does not allow dynamic exception specifications
+ 62 | throw( VpdException& );
+ | ^~~~~
+./src/libvpd-2/vpdretriever.hpp:74:33: error: ISO C++17 does not allow dynamic exception specifications
+ 74 | throw( VpdException& );
+ | ^~~~~
+src/vpdretriever.cpp:50:37: error: ISO C++17 does not allow dynamic exception specifications
+ 50 | string dbFileName ) throw( VpdException& )
+ | ^~~~~
+src/vpdretriever.cpp:62:39: error: ISO C++17 does not allow dynamic exception specifications
+ 62 | VpdRetriever::VpdRetriever( ) throw( VpdException& )
+ | ^~~~~
+make: *** [Makefile:660: src/vpdretriever.lo] Error 1
+
+As part of
+http://www.open-std.org/jtc1/sc22/wg21/docs/papers/2016/p0003r5.html,
+the dynamic exception specification have been removed. Remove the
+throw specifier, to specify that the function might throw an exception.
+
+Signed-off-by: Kamalesh Babulal <kamalesh@linux.vnet.ibm.com>
+Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
+---
+ src/libvpd-2/vpdretriever.hpp | 6 ++----
+ src/vpdretriever.cpp | 4 ++--
+ 2 files changed, 4 insertions(+), 6 deletions(-)
+
+diff --git a/src/libvpd-2/vpdretriever.hpp b/src/libvpd-2/vpdretriever.hpp
+index 0d91ac4..1be2664 100644
+--- a/src/libvpd-2/vpdretriever.hpp
++++ b/src/libvpd-2/vpdretriever.hpp
+@@ -58,8 +58,7 @@ namespace lsvpd
+ * @param dbFileName
+ * The file name for the VPD database.
+ */
+- VpdRetriever( string envDir, string dbFileName )
+- throw( VpdException& );
++ VpdRetriever( string envDir, string dbFileName );
+
+ /**
+ * Builds A VpdRetriever object that can be used for reading the
+@@ -70,8 +69,7 @@ namespace lsvpd
+ * this constructor, there were serious underlying issues that
+ * are not recoverable. Uses the default dir and filename
+ */
+- VpdRetriever( )
+- throw( VpdException& );
++ VpdRetriever( );
+ ~VpdRetriever( );
+
+ /**
+diff --git a/src/vpdretriever.cpp b/src/vpdretriever.cpp
+index 9f7e7a0..470047e 100644
+--- a/src/vpdretriever.cpp
++++ b/src/vpdretriever.cpp
+@@ -47,7 +47,7 @@ namespace lsvpd
+ const string VpdRetriever::UDEV_NOTIFY_FILE ( "/run/run.vpdupdate" );
+
+ VpdRetriever::VpdRetriever( string envDir,
+- string dbFileName ) throw( VpdException& )
++ string dbFileName )
+ {
+ try {
+ db = new VpdDbEnv( envDir, dbFileName, true );
+@@ -59,7 +59,7 @@ namespace lsvpd
+ }
+ }
+
+- VpdRetriever::VpdRetriever( ) throw( VpdException& )
++ VpdRetriever::VpdRetriever( )
+ {
+ struct stat vpd_stat,udev_stat;
+ const string vpddb = VpdRetriever::DEFAULT_DIR + VpdRetriever::DEFAULT_FILE;
diff --git a/sys-libs/libvpd/files/2.2.8-warnings.patch b/sys-libs/libvpd/files/2.2.8-warnings.patch
new file mode 100644
index 000000000000..1419de3dda49
--- /dev/null
+++ b/sys-libs/libvpd/files/2.2.8-warnings.patch
@@ -0,0 +1,52 @@
+From 72b75e1976b50372f07271a5235ee8e9c75bdac4 Mon Sep 17 00:00:00 2001
+From: Kamalesh Babulal <kamalesh@linux.ibm.com>
+Date: Mon, 21 Jun 2021 11:42:02 +0530
+Subject: [PATCH] vpddbenv_c: fix compile warnings
+
+src/vpddbenv_c.c: In function 'new_vpddbenv':
+src/vpddbenv_c.c:56:17: warning: 'strncat' specified bound 1 equals source length [-Wstringop-overflow=]
+ 56 | strncat( ret->fullPath, "/" , 1 );
+ | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+src/vpddbenv_c.c:58:17: warning: 'strncat' accessing between 258 and 9223372036854775804 bytes at offsets 514 and 257 may overlap 1 byte at offset 514 [-Wrestrict]
+ 58 | strncat( ret->fullPath, ret->dbFileName, strlen(ret->dbFileName) );
+ |
+ ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+
+While compiling the code with GCC-11 (Fedora 34), the GCC complains
+about src string length and N bytes mentioned in the strncat() are of
+same length. It gets suspicious, when strncat() mimics strcat(), the
+strcat() was replaced using strncat() by the commit 38de4e65205
+("libvpd: Convert strcat to strncat") as part of secure coding.
+
+refactor the code using snprintf(), making the code lean and keep the
+GCC happy as well.
+
+Signed-off-by: Kamalesh Babulal <kamalesh@linux.ibm.com>
+Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
+---
+ src/vpddbenv_c.c | 12 ++++--------
+ 1 file changed, 4 insertions(+), 8 deletions(-)
+
+diff --git a/src/vpddbenv_c.c b/src/vpddbenv_c.c
+index 96aecd3..bae36e9 100644
+--- a/src/vpddbenv_c.c
++++ b/src/vpddbenv_c.c
+@@ -50,14 +50,10 @@ struct vpddbenv * new_vpddbenv( const char *dir, const char *file )
+ ret->dbFileName[MAX_NAME_LENGTH] = '\0';
+ }
+
+- strncpy( ret->fullPath, ret->envDir , FULL_PATH_SIZE - 1);
+-
+- if (strlen(ret->fullPath) + 1 < FULL_PATH_SIZE)
+- strncat( ret->fullPath, "/" , 1 );
+- if (strlen(ret->fullPath) + strlen(ret->dbFileName) < FULL_PATH_SIZE)
+- strncat( ret->fullPath, ret->dbFileName, strlen (ret->dbFileName) );
+-
+- ret->fullPath[FULL_PATH_SIZE - 1] = '\0';
++ if ( ( strlen( ret->envDir ) + strlen( ret->dbFileName ) + 1 ) <
++ FULL_PATH_SIZE )
++ snprintf( ret->fullPath, FULL_PATH_SIZE,
++ "%s/%s", ret->envDir, ret->dbFileName );
+
+ rc = sqlite3_open( ret->fullPath, &(ret->db) );
+ if( rc != SQLITE_OK )
diff --git a/sys-libs/libvpd/libvpd-2.2.8.ebuild b/sys-libs/libvpd/libvpd-2.2.8-r1.ebuild
index 0c38cecb19fc..3b69e327edd6 100644
--- a/sys-libs/libvpd/libvpd-2.2.8.ebuild
+++ b/sys-libs/libvpd/libvpd-2.2.8-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,6 +18,11 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}/2.2.8-gcc11.patch"
+ "${FILESDIR}/2.2.8-warnings.patch"
+)
+
src_prepare() {
default
eautoreconf