summaryrefslogtreecommitdiff
path: root/sys-libs/libcxxabi/libcxxabi-18.1.0_rc2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libcxxabi/libcxxabi-18.1.0_rc2.ebuild')
-rw-r--r--sys-libs/libcxxabi/libcxxabi-18.1.0_rc2.ebuild15
1 files changed, 4 insertions, 11 deletions
diff --git a/sys-libs/libcxxabi/libcxxabi-18.1.0_rc2.ebuild b/sys-libs/libcxxabi/libcxxabi-18.1.0_rc2.ebuild
index 2c496689828b..d45de5993114 100644
--- a/sys-libs/libcxxabi/libcxxabi-18.1.0_rc2.ebuild
+++ b/sys-libs/libcxxabi/libcxxabi-18.1.0_rc2.ebuild
@@ -4,8 +4,8 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake-multilib flag-o-matic llvm llvm.org python-any-r1 \
- toolchain-funcs
+inherit cmake-multilib flag-o-matic llvm.org llvm-utils python-any-r1
+inherit toolchain-funcs
DESCRIPTION="Low level support for a standard C++ library"
HOMEPAGE="https://libcxxabi.llvm.org/"
@@ -45,16 +45,9 @@ python_check_deps() {
python_has_version "dev-python/lit[${PYTHON_USEDEP}]"
}
-pkg_setup() {
- # darwin prefix builds do not have llvm installed yet, so rely on bootstrap-prefix
- # to set the appropriate path vars to LLVM instead of using llvm_pkg_setup.
- if [[ ${CHOST} != *-darwin* ]] || has_version sys-devel/llvm; then
- LLVM_MAX_SLOT=${LLVM_MAJOR} llvm_pkg_setup
- fi
- python-any-r1_pkg_setup
-}
-
multilib_src_configure() {
+ llvm_prepend_path "${LLVM_MAJOR}"
+
if use clang; then
local -x CC=${CHOST}-clang
local -x CXX=${CHOST}-clang++