summaryrefslogtreecommitdiff
path: root/sys-libs/libcxx/libcxx-10.0.0.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libcxx/libcxx-10.0.0.9999.ebuild')
-rw-r--r--sys-libs/libcxx/libcxx-10.0.0.9999.ebuild13
1 files changed, 3 insertions, 10 deletions
diff --git a/sys-libs/libcxx/libcxx-10.0.0.9999.ebuild b/sys-libs/libcxx/libcxx-10.0.0.9999.ebuild
index 83d8eeaa8c40..f5f67053d776 100644
--- a/sys-libs/libcxx/libcxx-10.0.0.9999.ebuild
+++ b/sys-libs/libcxx/libcxx-10.0.0.9999.ebuild
@@ -3,21 +3,14 @@
EAPI=7
-# Ninja provides better scalability and cleaner verbose output, and is used
-# throughout all LLVM projects.
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
-# (needed due to CMAKE_BUILD_TYPE != Gentoo)
-CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-
-inherit cmake-multilib git-r3 llvm multiprocessing python-any-r1 \
+inherit cmake-multilib llvm llvm.org multiprocessing python-any-r1 \
toolchain-funcs
DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
HOMEPAGE="https://libcxx.llvm.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/libcxx.git
- https://github.com/llvm-mirror/libcxx.git"
+LLVM_COMPONENTS=( libcxx )
+llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="0"