summaryrefslogtreecommitdiff
path: root/sys-libs/libcap-ng/libcap-ng-0.8.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libcap-ng/libcap-ng-0.8.4-r1.ebuild')
-rw-r--r--sys-libs/libcap-ng/libcap-ng-0.8.4-r1.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/sys-libs/libcap-ng/libcap-ng-0.8.4-r1.ebuild b/sys-libs/libcap-ng/libcap-ng-0.8.4-r1.ebuild
index f69c5049ed83..f6c6b3dbba65 100644
--- a/sys-libs/libcap-ng/libcap-ng-0.8.4-r1.ebuild
+++ b/sys-libs/libcap-ng/libcap-ng-0.8.4-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=8
# Keep an eye on Fedora's packaging (https://src.fedoraproject.org/rpms/libcap-ng/tree/rawhide) for patches
# Same maintainer in Fedora as upstream
PYTHON_COMPAT=( python3_{10..12} )
-inherit autotools flag-o-matic libtool python-r1
+inherit autotools flag-o-matic out-of-source-utils python-r1
DESCRIPTION="POSIX 1003.1e capabilities"
HOMEPAGE="https://people.redhat.com/sgrubb/libcap-ng/"
@@ -27,17 +27,14 @@ BDEPEND="python? ( >=dev-lang/swig-2 )"
PATCHES=(
"${FILESDIR}"/${P}-swig.patch
+ # https://bugs.gentoo.org/928450
+ "${FILESDIR}"/${P}-slibtool.patch
)
src_prepare() {
default
- if use prefix ; then
- sed -i "s@cat /usr@cat ${EPREFIX}/usr@" bindings/python*/Makefile.am || die
- # bug #668722
- eautomake
- fi
- elibtoolize
+ eautoreconf
}
src_configure() {
@@ -47,6 +44,7 @@ src_configure() {
local myconf=(
$(use_enable static-libs static)
+ --with-capability_header="${ESYSROOT}"/usr/include/linux/capability.h
)
local pythonconf=(